7 Replies Latest reply on Nov 11, 2013 1:39 PM by Dillik

    FMP stops responding to modifier keys and arrowkeys

    Dillik

      Summary

      FMP stops responding to modifier keys and arrowkeys

      Product

      FileMaker Pro

      Version

      FMP 12v4, 12v5

      Operating system version

      OS X 10.7.5

      Description of the issue

      At various times (sometimes several times a day), my FileMaker will just stop recognizing keyboard shortcuts which involve modifier keys (it also fails to recognize arrowkeys and a few other misc. keys such as forward-Delete at this point). Text editing continues to work fine (so does Shift to capitalize), and the general behavior of FileMaker doesn't get disrupted (I can change windows, change records, enter Manage dialogs, etc.). All commands work by selecting them with the mouse; it's simply certain keyboard commands which go unrecognized.

      Quitting FileMaker and restarting does NOT solve the problem; logging out my OS session and coming back in does. It isn't tied to any specific Custom Menu Set or file. When it happens, the problem is strictly limited to FileMaker; other programs I had open at the time continue to work exactly as expected. I've not found any other users (or machines) that seem to have this problem.

      (I have an easy workaround listed below; my reason in submitting this report is mostly just to present this workaround to anyone who may be searching for a solution, because it was maddening until I figured it out.)

      Steps to reproduce the problem

      This problem seems to happen at random, though I suspect there's some triggering event (probably mouse-related?) I just haven't isolated yet.

      Configuration information

      I'm using an Apple wired extended keyboard which exhibits no other strange issues.

      Instead of a mouse, I'm using a Magic Trackpad, and my OS has the BetterTouchTool software installed to customize some of my trackpad gestures. This problem may, for all I know, be caused by BTT, though I find it peculiar that the problem is invariably limited to FileMaker. I've not tried working for extended periods with BTT disabled because it greatly boosts my productivity and I've found no reliable method for triggering this issue (I might be waiting all day or multiple days between occurrences, and that's a long time to go without my custom gestures).

      Workaround

      RIGHT-CLICK! This problem was enormously frustrating until I stumbled onto the workaround: right-clicking anything in FileMaker which generates a context menu suddenly restores full keyboard functionality.

        • 1. Re: FMP stops responding to modifier keys and arrowkeys
          TSGal

               Dillik:

               Thank you for your post.

               Do you have access to another computer?  If so, does the issue also occur on that computer?

               If quitting and relaunching FileMaker Pro does not fix the issue, then there is something else occurring deeper in the OS.

               It may or may not be related to FileMaker's incompatibility with BetterTouchTool, but the only way to be sure is to temporarily turn off BetterTouchTool, even though it cuts your "productivity".  I searched our issues database, and I don't see an entry for BetterTouchTool.  Have you contacted BetterTouchTool to see if there have been any incompatibilities reported?  Don't get me wrong...  I'm not trying to point fingers at anyone, but only trying to get as much information as possible before submitting an issue.

               Please keep me updated with any progress.

               TSGal
               FileMaker, Inc.

          • 2. Re: FMP stops responding to modifier keys and arrowkeys
            Dillik

                 Thanks for the reply, TSGal. No one else in my office has reported having this problem (and point of interest: I'm the only one using BTT, and also the only one with a Magic Trackpad). I also see no mention of FileMaker in any bugs previously reported to the BTT developer.

                 I'll see if I can live without BTT for what seems like a long enough period to have come across the bug otherwise.

            • 3. Re: FMP stops responding to modifier keys and arrowkeys
              TSGal

                   Dillik:

                   I performed an internet search for:  BetterTouchTool FileMaker

                   See post #38
              http://blog.boastr.net/secondbar-gives-you-a-second-menubar-for-osx/

                   See post #48:
              http://blog.boastr.net/yay-first-exam-done/

                   Although neither of these posts mention your specific issue, they do report an issue with BetterTouchTool and FileMaker Pro.

                   Also, keep in mind that it may not be just BetterTouchTool, so try running BetterTouchTool without the trackpad to see if that is a factor.

                   TSGal
                   FileMaker, Inc.

              • 4. Re: FMP stops responding to modifier keys and arrowkeys
                Dillik

                     Er, well, the first link regards a different product (same developer, though), and the second link doesn't describe the poster's reason for wanting BTT disabled when he begins editing scripts. There may well be any number of issues between FMP and BTT, but I don't think these posts establish that.

                     Anyway, still trying to make it bug out with BTT disabled in FMP; no luck so far. I will say that I've previously encountered the problem without a Magic Trackpad connected, but this would've involved the laptop's built-in trackpad with BTT running. The difference there is that the right-click mechanism would've been different (on my built-in trackpad, I don't have tiptap-right set up as a right-click gesture as I do for the Magic Trackpad). Still doesn't rule out a general trackpad compatibility issue, of course, but my money's on BTT being involved somehow.

                • 5. Re: FMP stops responding to modifier keys and arrowkeys
                  Dillik

                       This is strange. BTT is disabled for FMP, and yet I just encountered a situation where Get(ActiveModifierKeys) kept reporting 4 (Control) despite Control not being pressed (I pressed and unpressed all my Control keys - external keyboard and built-in - to make sure no key was stuck, physically or otherwise). It kept reporting 4 in scripts and in the data viewer (I refreshed the data viewer for each keypress change, of course) even though the FM interface didn't behave as it would with Control pressed (on Mac, Control-click should register as a right-click; that didn't happen). Modifier key behavior seemed normal, except as far as the calculation engine was concerned, the modifier key remained 4 (even when I tried adding new keys, such as Shift to try making the result 5).

                       This persisted until I logged out my OS session; restarting FileMaker did nothing. This is definitely not the bug I was initially reporting, whereby modifier-based shortcuts were unrecognized and a right-click cleared it up, but it's hard not to suspect a connection of some sort given that both problems involved modifier keys and FileMaker (and even more suspiciously, Control-key functionality seems to be a common theme). I'll now try running with BTT not running at all to see what happens.

                  • 6. Re: FMP stops responding to modifier keys and arrowkeys
                    philmodjunk

                         If you have another keyboard that's in good shape, you might also swap them for a while just to rule out problems with your keyboard. If a key is wearing out, it might function correctly in terms of the mechanical key action but still be sending a specific "keydown" to the computer even though the key is up.

                    • 7. Re: FMP stops responding to modifier keys and arrowkeys
                      Dillik

                           Right, and that's one of the things I try to rule out first with these bugs, but in this case, these are issues with just one program (FileMaker) and actually just part of the program. In the original bug, only parts of FileMaker cease responding to shortcuts (Manage Scripts, for instance, actually keeps receiving the shortcut keys even though the rest of FMP doesn't). And in the recent bug, only the calculation engine reported Control being pressed, but nothing else behaved as it would have with an actual Control keypress (or even a falsely reported Control keypress).