1 2 3 Previous Next 33 Replies Latest reply on Mar 17, 2009 7:14 AM by TSGal

    FMP10 crash on Save as PDF

    michno

      Summary

      FMP10 crash on Save as PDF

      Description of the issue

      FileMaker Pro 10 Advanced / Windows XP FileMaker Pro 10 crashes when I perform a script involving the Save as PDF step. Same thing if I do it manually (go to the appropriate layout and Select Save as PDF in the File menu). Will have to re-install FMP9 to get the job done... :( 

        • 1. Re: FMP10 crash on Save as PDF
          michno
            

          I re-installed FMP 9 Advanced and everything works fine with this version.

           

          Also (forgot to mention), the database is hosted on FMP 10 Server running on a Windows 2003 Server (64-bit).  And the Save as Excel feature works fine in FMP10, it's just the PDF thing that crashes...

          • 2. Re: FMP10 crash on Save as PDF
            michno
               Crashes under Mac OS X too... :(
            • 3. Re: FMP10 crash on Save as PDF
              TSGal

              michno:

               

              Thank you for your posts.

               

              Unfortunately, I cannot duplicate the problem.  I am able to Save as PDF on both Windows (XP SP3) and Macintosh (10.5.5).

               

              Do you have access to another Windows machine?  If so, can you try printing there?  If it works, then we will need to determine what is the difference between the two computers.

               

              Can you tell me a bit more about the Mac?  OS version?  On the Mac, remove the following file and try again:

               

              Home -> Library -> Application Support -> Adobe -> TypeSpt -> AdobeFnt08.lst

               

              TSGal

              FileMaker, Inc. 

              • 4. Re: FMP10 crash on Save as PDF
                BruceR
                   No problem here (one brief test). OSX 10.5.6
                • 5. Re: FMP10 crash on Save as PDF
                  michno
                    

                  Thanks for your reply! 

                  Mac OS and Windows are running on the same machine here, MacBook with Windows XP (SP3) under BootCamp and Mac OS X 10.5.6 on the brighter side of life.

                   

                  I have actually managed to save to PDF once on the Mac now, using a different database than in the other cases. I'm aiming to do more troubleshooting tomorrow. I'm guessing it might be font issue. Back in the old days (say FMP 5.5) you could create a working cross-platform solution in FileMaker (printouts looked the same regardless if they were printed from a Mac or from a Win-box). With FMP9 I found this was not the case. I really tried everything. What I have now is a solution with all layouts in Verdana. I have copied the Verdana font files from Windows to Mac OS so the exact same fonts are used on both platforms, but the line-spacing is still totally out of whack. Sadly, all printing and layout work has to be done under Windows. I was hoping FMP10 would be better, but it seems not. :(

                   

                  Still, I'll get back to you when I've done some more tests. 

                  • 6. Re: FMP10 crash on Save as PDF
                    michno
                      

                    OK, so today I first tried a manual Save as PDF (as opposed to scripted). It worked. I was thrilled. I then tried the scripted. Crash. After that both saves results in crashing.

                    So I changed the font in the print layout that's crashing. (All this in done in Windows). Still crashes. Maybe not a font issue after all. I just don't know. When I open the solution in FMP 9 Advanced everything still works just fine. :( :(

                     

                    More testing: I went to another machine in the office (Win XP SP3) running FMP10 (standard). Same thing, crash. So at least it's not confined to my machine... 

                    • 7. Re: FMP10 crash on Save as PDF
                      fabriceN
                        

                      there are two causes to this bug (legacy from FM9)

                      - conflict with AdobeAcrobat web plug-in (you can remove it from your internet plug-in folder), but of course it means that you have to view the pdf files with Safari.

                      - run Onyx (freeware) and clean all the cache. Usually solves the issue. 

                      • 8. Re: FMP10 crash on Save as PDF
                        michno
                          

                        Thanks for trying to help out Fabrice.

                         

                        However, it's obviously not an FMP9 issue since everything works just fine and dandy in 9.

                         

                        Also, the problem occurs both under OS X and Windows, although it seems to be slightly worse in Windows. 

                        • 9. Re: FMP10 crash on Save as PDF
                          fabriceN
                             Sorry, posted in the wrong thread (there shouldn't be so many threads about printing/crashing, should it ?). Indeed the issue I was replying to is a Mac OS X Leopard specific issue.
                          • 10. Re: FMP10 crash on Save as PDF
                            TSGal

                            michno:

                             

                            Sorry for the late reply.  I was out ill these past few days.

                             

                            This is what I did:

                             

                            1. I opened a database file.

                             

                            2. I create a new script with one script step:

                             

                            Save Records as PDF [Restore; No dialog; "untitled.pdf"; Automatically open; Records being browsed ]

                             

                            3. I executed the script with 51 records.  It took a while, but the file opened.  102 pages (two page layout).

                             

                            That's it.  If you have specific script steps you want me to try, let me know.  Otherwise, I'm not sure where else to look than what has already been mentioned.

                             

                            TSGal

                            FileMaker, Inc. 

                            • 11. Re: FMP10 crash on Save as PDF
                              michno
                                

                              Thanks for trying TSGal (that's not really your name is it? ;)

                               

                              I haven't had time to get to the bottom with this, but what I've found is that another script in the same solution that exports/saves the same records using the same layout only with all pages rather than just page 2-3 does not crash. Both scripts creates a PDF and then also appends pages to it from a different layout.

                               

                              I'll post again when I find what's wrong or when I get completely stuck. :) 

                              • 12. Re: FMP10 crash on Save as PDF
                                michno
                                  

                                Back again. Today I sat down to try and sort this out. It didn't go so well...

                                 

                                As I mentioned in my previous post I have 2 scripts in this solution that are identical with 1 difference: script A saves pages 1-2 of a specific layout to PDF and then appends other pages to that PDF. Script B saves pages 2-3 of the same layout to PDF and then appends. Script B crashes FMP10, but script A does not.

                                 

                                I now decided to try to save pages to PDF directly from that layout by going to the File menu -> Save As... PDF, thus bypassing the script (and then also the append and so on...). Here's how it worked out:

                                Saving pages 1-2: works fine

                                Saving pages 2-3: crashes

                                Saving page 1 only: works fine

                                Saving page 2 only: crashes

                                Saving page 3 only: crashes

                                Saving all pages (1-3): works fine (!!!)

                                 

                                Can you believe this?

                                 

                                I had an old duplicate of that layout in the file so I now turned to that layout. I selected all in the layout and changed the font from Verdana to Arial. No luck. Crashes or works just as above.

                                I then removed the only graphic object from page 2. No luck. (The graphic is also on page 1 so it was a long shot but...). I then removed everything from page 2 and tried to save to PDF. Crash!!!

                                 

                                I created a new blank layout and copied all items from the old layout. Crashes just the same.

                                 

                                I then (in complete desperation) dug out a really old copy of my database from my backups. This is like from when it was almost new so that exact layout did not yet exist, but there was a layout which later evolved into the crashing one. Tried to save 2 pages to PDF. Guess what? Yes, it crashes.

                                 

                                Now the deal is that other layouts in the solution (the present version, not the backup) with similar looks (items have probably been copied to these layouts from the one that crashes) works fine.

                                 

                                Also, it may be good to recall that everything works just fine when I open the solution in FMP9!

                                 

                                So, is my file corrupt? If so, then it has been corrupt almost from the beginning as the backup test above shows. When I had recently installed FMP10 and first ran into this problem I did a Recover of the file with FMP10. It said the file was bad and should not be used. Not nice, so I took a recent backup and tried again. Same result. I then took the same backup file (not the now recovered file) and ran it through FMP9's Recover. It reported nothing odd. I then took this new file and ran it through the FMP10 Recover routine and it now said the file was just fine. What do I make of this??

                                 

                                Also, may I point out that the log file created by FMP10 after recovery is just useless since it contains no information of what was not OK in the file.

                                 

                                So TSGal, I am completely and utterly stuck here. I do not have a clue as to what is going on and any help is appreciated. :) 

                                • 13. Re: FMP10 crash on Save as PDF
                                  TSGal

                                  michno:

                                   

                                  Thank you for the additional information.

                                   

                                  From your description, it seems to work only when page 1 is involved.  All other attempts fail.

                                   

                                  Working off of that, I "Save/Send Records as PDF" on a Mac, starting at page 2, and it worked fine.  However, I did get an error message when I tried it on Windows XP.  However, on a second file, it did NOT have a problem.  The only difference I could tell was a Container field.  When I add a Container field to my Mac file, it still worked.

                                   

                                  The jury is still out on this one, so I'll get some other people involved and get back to you.

                                   

                                  TSGal

                                  FileMaker, Inc. 

                                   

                                   

                                   

                                   

                                  • 14. Re: FMP10 crash on Save as PDF
                                    TSGal

                                    michno:

                                     

                                    Update....

                                     

                                    All my other layouts worked fine except for one.  I noticed it was more than one page long, so when I reduced the layout size to one page, the problem went away.  Is this the case for you?

                                     

                                    TSGal

                                    FileMaker, Inc. 

                                    1 2 3 Previous Next