9 Replies Latest reply on Jul 3, 2014 1:41 PM by RickWhitelaw

    FMS 13 Admin console not responding

    Markus Schneider

      Summary

      FMS 13 Admin console not responding

      Product

      FileMaker Server

      Version

      13.0x

      Operating system version

      OSX 10.9.3/10.9.2

      Description of the issue

      After some weeks of usage, the admin-console is no longer working. Can't connect. Further on, using the fmsadmin-commands, fmsadmin restart ADMINSERVER returns a message 'does not exist', dito fmsadmin stop SERVER

      After a restart of the machine, everthing runs smooth again - for some weeks

      Please note: The FMS works smooth, users can connect, schedules are exected without any problems

      The latest update is _not_ installed here -> there was nothing about this issue in the release notes..

      Steps to reproduce the problem

      - FMS 13
      - running with low traffic for some weeks
      - open the admin console using a web-browser
      - open the OSX terminal, try fmsadmin restart ADMINSEVER

      Expected result

      FMS (admin console) runs for more than some weeks

      Actual result

      admin console stops responding after some weeks

      Exact text of any error message(s) that appear

      will have to wait until the next time... server is booting

      Configuration information

      MacMini first UniBody version, 8GB Ram, nothing than OSX 10.9.x and FMS 13

      Workaround

      restarting the Mac

        • 1. Re: FMS 13 Admin console not responding
          TSGal

               markus schneider:

               Thank you for your post.

               It is difficult to determine what is causing the problem based on your post.  If you look at the event.log or the system.log, do you see anything out of the ordinary?  I doubt the event.log would show anything because FileMaker Server is still running, as clients can still connect to hosted files.

               For clarification, it appears you are launching Admin Console from the server.  Correct?  Regardless, have you tried to connect to Admin Console from another computer?

               Any other information you can provide may be helpful in narrowing down the possible causes.

               TSGal
               FileMaker, Inc.

          • 2. Re: FMS 13 Admin console not responding
            RickWhitelaw

                 the last time I tried to launch the Admin Console on the server machine it was no dice. I can access it from other machines however. I just haven't bothered to try again. 

            • 3. Re: FMS 13 Admin console not responding
              Markus Schneider

                   Thank You very much for Your answer!

                   I _believe_ that a couple of weeks ago, I tried to access the console from another machine. Since it happens only after running for some weeks, I'm unsure. Last weekend, I just tried from the server machine - and restarted that Mac. Now, everything runs fine.

                   The only things I'm sure about is that it happens after a longer time of use - and I don't have the latest patch of FMS (we got customers where we can't roll updates quickly - and when the release notes more or less just show WD stuff...)

                   We got several FMS13 running - and all of them have this issue in common. (and restarting helps)

              • 4. Re: FMS 13 Admin console not responding
                IsaacKnoflicek

                     I believe I'm experiencing the same issue, only I'm experiencing it every time I reboot the server.  I'm also running 10.9.3 and it Filemaker server 13 runs fine after a fresh install, however after a reboot the admin console won't load and when I try to run "fmsadmin start adminserver" I'm told the object does not exist.

                     I have noticed that if I go into terminal, navigate to Library/Application Data/Filemaker/Filemaker Server and run "./launcher -load" followed by "./launcher -start" then I am able to successfully run "fmsadmin start adminserver" however even after manually starting and restarting all filemaker services I'm still unable to connect.

                     The only workaround I've found is to run the "FileMaker Server 13.0v2 Updater", after that runs I'm again able to get to the admin console.

                • 5. Re: FMS 13 Admin console not responding
                  TSGal

                       markus schneider and RIck Whitelaw:

                       Thank you for the information.

                       Have you upgraded to FileMaker Server 13.0v2?

                       Since this appears to occur after a "few weeks", is there anything in the system logs that looks out of the ordinary?

                       What browser and browser version are you using on the server to access Admin Console?

                       When you try to connect, do you get an error message?  What are the exact symptoms?

                       TSGal
                       FileMaker, Inc.

                  • 6. Re: FMS 13 Admin console not responding
                    Markus Schneider

                         I'll upgrade one of the servers to the latest version of FMS13 - it will take some weeks until I can say if it helped... 

                    • 7. Re: FMS 13 Admin console not responding
                      adrianprice

                           I can't launch the admin console, local or remote, and webdirect is not working. This has happened before, and the reinstall of FMS would fix it, but not now. Java had updated to update 60, but I have rolled that back to update 55 and it didn't help. FMP and FM Go clients can still use the server.

                           FMS13v2 on Windows Server 2008.

                      • 8. Re: FMS 13 Admin console not responding
                        TSGal

                             Adrian Price:

                             Thank you for your post.

                             Were you trying to install Java and FileMaker Server at the same time?  FileMaker Server 13.0v2 has been certified to run under Java 7 update 60.  Once the Java update has been installed, then install FileMaker Server 13.0v2.

                             Let me know if you continue to run into difficulty.

                             TSGal
                             FileMaker, Inc.

                        • 9. Re: FMS 13 Admin console not responding
                          RickWhitelaw

                               TSGal,

                                

                                   I'm running the latest FMS version accessing with the latest version of Safari on MBP, MacPro and iPad. Server is Mac Mini with latest OS. I haven't tryed to access the Admin Console locally for around ten days. The only reason I did try was I had rebooted the server machine and was testing everything. At that point I couldn't access the Console locally. However, though I should be able to do this, the fact that I've been able to access it from three other machines obviates the need to access it on the server machine. I just never do it. I rarely  turn on the screen which happens to be my tv.

                                   Not much help, but wanted to point out that my lack of local access also was immediately after a reboot.