1 2 Previous Next 19 Replies Latest reply on Apr 17, 2017 5:18 PM by rd.trammel

    FMS 14.02 Webserver status is Grey but everything is working

    MattMatthews

      Summary

      FMS 14.02 Webserver status is Grey but everything is working

      Product

      FileMaker Server

      Version

      14.02

      Operating system version

      MS Server 2012 R1

      Description of the issue

      FMS 14.02 Webserver status is Grey but everything is working (FM Pro, WebDirect, PHP); is this normal/OK?

      Steps to reproduce the problem

      Open Admin console and view web server status.

      Expected result

      WebServer Status is Green

      Actual result

      WebServer Status is Gray

      Exact text of any error message(s) that appear

      no error

      Configuration information

      none

      Workaround

      none

        • 1. Re: FMS 14.02 Webserver status is Grey but everything is working

          Matt Matthews:

           

          Thank you for the post. 

           

          The issue described is definitely not expected, but if everything is working properly the grey dot could be a false flag. Some questions to assist us with narrowing this down:

           

          1. What are the hardware specifications for the host machine (RAM, CPU)?

          2. Is any third party security or antivirus software installed?

          3. Does redeploying from the Admin Console correct the issue?

          4. Since the Web Server is used for uploading database files, does uploading a database work?

           

          TSFalcon

          FileMaker, Inc.

          • 2. Re: FMS 14.02 Webserver status is Grey but everything is working
            MattMatthews

            Hi TS, thanks much for the help; here are answers:

             

            1. What are the hardware specifications for the host machine (RAM, CPU)? Xeon E3-1240 v3 3.4 GHZ, 16GB ram

            2. Is any third party security or antivirus software installed? None and I have tested with the MS firewall disabled

            3. Does redeploying from the Admin Console correct the issue?  Yes tried to redeploy and still have the issue.

            4. Since the Web Server is used for uploading database files, does uploading a database work?  I have not tried this yet and I will not be back to the server until Monday.

            • 3. Re: FMS 14.02 Webserver status is Grey but everything is working
              MattMatthews

              4. Since the Web Server is used for uploading database files, does uploading a database work?  This does not seem to be working; I get an error of invalid user/password and cannot upload.

              What next?

              • 4. Re: FMS 14.02 Webserver status is Grey but everything is working

                Matt Matthews:

                 

                Thank you for the reply. 

                 

                “This does not seem to be working; I get an error of invalid user/password and cannot upload.

                What next?”

                 

                Appears as if something is preventing our connection to IIS, preventing FileMaker Server’s ability to build our instance of a Web Server. Since redeployment didn’t fix the issue, I would backup the databases, save schedules and groups, and then perform following next steps:

                 

                1. Uninstall all of the following from Add/Remove:

                 

                    a. FileMaker Server 14

                    b. Java (all versions)

                    c. Bonjour

                    d. IIS URL Rewrite Module

                    e. Microsoft Application Request Routing

                    f. Microsoft External Cache for IIS

                    g.  Microsoft Visual C++ 2012 Redistributable Package (x64) 

                    h. Microsoft Web Farm Framework

                 

                2. Remove the IIS role from Server Manager

                3. Restart the computer

                4. Delete the inetpub folder located on the C:/ drive

                5. Delete or rename the FileMaker Server folder located on the C:/ drive

                 

                Afterwards, reinstall FileMaker Server 14.0.2 with the full installer located in your store purchase email. 

                 

                Please keep me updated with any progress. 

                 

                TSFalcon

                FileMaker, Inc.

                • 5. Re: FMS 14.02 Webserver status is Grey but everything is working
                  MattMatthews

                  Hi, I have reinstalled and everything work until I loaded my PHP files in the 'conf' directory; then the webserver stop (greyed out).  What is up; help?

                  Also, we notice that the install will not runt if the setup.exe if it is not on the C Drive.  I download to an E: drive to save my install files.  Is this a known issue?

                  • 6. Re: FMS 14.02 Webserver status is Grey but everything is working

                    Matt Matthews:

                     

                    Thank you for the reply. 

                     

                    “Also, we notice that the install will not runt if the setup.exe if it is not on the C Drive.  I download to an E: drive to save my install files.  Is this a known issue?”

                     

                    The only times I have encountered this behavior is if the user account on the computer used to install is either:

                     

                    1. Not a Admin Account

                    2. A domain admin account (with limited access privileges)

                     

                    Running from the C:/ drive places the installation outside of the Windows directory permissions and is run as an administrator. 

                     

                    “everything work until I loaded my PHP files in the 'conf' directory”

                     

                    Specifically which directory?

                     

                    Are the PHP files using our newest built-in PHP API or a third party API?

                     

                    TSFalcon

                    FileMaker, Inc.

                    • 7. Re: FMS 14.02 Webserver status is Grey but everything is working
                      MattMatthews

                      C Drive Issue: I'm using an Admin account

                      PHP Issue: using the Filemaker/HTTPServer/conf directory

                      Also, I'm using the same PHP files that were created in Note++ and in used with FMServer13 now; there has not been any sort of recompile to these files (if something like this exists)

                      Thoughts?

                      • 8. Re: FMS 14.02 Webserver status is Grey but everything is working

                        Matt Matthews:

                         

                        Thank you for the reply. 

                         

                        At this point, I would like to see the PHP files for Testing to see if I can replicate. Please check your inbox at the top of this page for the submission instructions. 

                         

                        TSFalcon

                        FileMaker, Inc.

                        • 9. Re: FMS 14.02 Webserver status is Grey but everything is working
                          MattMatthews

                          The PHP files have been emailed as instructed.  Thx

                          • 10. Re: FMS 14.02 Webserver status is Grey but everything is working
                            MattMatthews

                            FYI, I uninstalled again per the above directions and then reinstalled (in the same directory this time) with the PHP files already existing in the HTTPServer directory.  Everything seems to be working now with the Web server (not Greyed out).  

                            I'm going to let is run over the weekend, test more and see if all stays stable.

                            • 11. Re: FMS 14.02 Webserver status is Grey but everything is working

                              Matt Matthews:

                               

                              Thank you for the reply.

                               

                              This is to confirm I received the files from my technical support contact. Since everything appears to now be working, I will hold off on further testing. Please keep me updated if anything changes. 

                               

                              TSFalcon

                              FileMaker, Inc.

                              • 12. Re: FMS 14.02 Webserver status is Grey but everything is working
                                johnnyb

                                I'm having this kind of problem on a fresh installation, with the "Web server" light gray, unable to upload database files, and incidentally, also unable to download files in containers via web direct.

                                 

                                I wonder if it's related to the user logged-in during installation; ordinarily I'm logged in with my own domain account, which has full administrative privileges, but I might have been logged in as the server's local admin account when I ran the FMS installer… or the other way around. Or I might have been local admin when I added the IIS role, and domain user when installing FMS.

                                 

                                Where does the "connection" happen between FMS and IIS? Should I be reviewing permissions in the IIS console?

                                • 13. Re: FMS 14.02 Webserver status is Grey but everything is working
                                  alan_barker

                                  I've just been bit by this issue.  I deployed fms14.02 on a test machine about a month back, and apparently did NOT notice that the Web Service status was grayed out.  Everything worked, but that Test machine's Admin console was always squirrelly - not accessible from a remote browser.  Not issues, for several weeks, so I deployed the fms 14.02 to my production machine.  Apparently again the Web Service status was again grayed out, and I failed to notice it.

                                   

                                  Last night I had a hard crash of my production fms14.02 service on our Windows Server 2008 R2 VM; and despite hours of starting and restarting the service, and the entire VM - my production machine's admin console is totally inaccessible from a remote browser.  Today, at noon, I'm going to take down our production environment, so that I can roll back to fms14.02.  This action on our test box looks like it corrects the Web Service status - which I suspect is the reason for the admin console being inaccessible.  By Inaccessible - I mean a web page that states "ERR_CONNECTION_RESET", and the only option ois Reload - which does nothing.

                                   

                                  Before the crash - my production Admin console worked perfectly - but I can not state for an absolute fact whether the Web Service status was grayed out, or not.

                                   

                                  This machine is critical for our business, with nearly 200 simultaneous users.

                                   

                                  I will try and post an update after lunch.

                                   

                                  Alan Barker

                                  Nidec Motor Corporation

                                  • 14. Re: FMS 14.02 Webserver status is Grey but everything is working
                                    johnnyb

                                    I got my WebDirect downloads working again, but the web console is still unavailable from a remote machine, I'm still having the web server status grayed out, and Web Publishing Engine starts and dies after reboot. I have to start it manually in the web console, which I can reach only from the server itself at localhost:16001.

                                     

                                    I rebuilt a fresh Windows 2008 R2 instance, ran all the updates, and installed IIS and FMS as the same user (with domain admin privileges).

                                     

                                    I configured FMS with the deployment assistant when it was at 14.0, and I noticed that the web server was grayed out and web engine didn't start even there. I then installed the update to 14.0.2, though nothing changed.

                                     

                                    I'm out of ideas, and I'm struggling because this too is on a production server and I don't have many opportunities to troubleshoot.

                                    1 2 Previous Next