2 Replies Latest reply on Jul 9, 2010 11:15 AM by TSGal

    FMSA 11 fmserver_helperd not cleaning up zombie processes

    Wodin

      Summary

      FMSA 11 fmserver_helperd not cleaning up zombie processes

      Description of the issue

      Summary fmserver_helperd does not clean up after dead child processes.FileMaker Product(s) involved FileMaker Server Advanced 11 FMSA 9 did not do this. I have not tried FMSA 10.Operating System(s) involved Mac OS X Server 10.5.x, Mac OS X Server 10.6.x.Detailed description of the issue FMSA 11's fmserver_helperd seems to accumulate zombies over time. In particular, shell processes and FM Web Publishing app processes. In particular shell processes and FM Web Publishing processes, but once there was an fmxdbc_listener processes as well. Normally immediately after a reboot, there will be a single "sh" process zombie whose parent process is fmserver_helperd. After a while (which could be a number of days) there are often one or more FM Web Publishing zombie processes too.Exact steps to reproduce the issueInstall FMSA 11 with all components on one machine (OS X 10.5 or 10.6.)Enable IWP. (Not sure if this is necessary.)Allow people to connect to one or more databases via IWP and wait.Check for zombies.Expected Result There are no zombie processes listed.Actual Result $ ps axo pid,ppid,stat,comm | awk '$1 == "PID" || $6 ~ /fmserver_helperd/ || $3 == "Z"'
        PID  PPID STAT COMM
      27989 32775 Z    (sh)
      32775     1 Ss   /Library/FileMaker Server/Database Server/bin/fmserver_helperd
      32820 32775 Z    (FM Web Publishin)
      33239 32775 Z    (FM Web Publishin)i.e. the fmserver_helperd process (32775) has three dead children that it has not reaped. It also has a living FM Web Publishing process not listed above.Exact text of any error message(s) that appeared N/AAny additional configuration information/troubleshooting that is relevant to the issue FMS has been re-installed various times on the original machine and also on a newly installed OS X 10.6 machine. Both machines were originally not on the latest versions of Leopard/Snow Leopard, but have since been upgraded and the problem persists. It appears as if fmserver_helperd is just never calling the wait() or equivalent system calls to clean up after dead children.Any workarounds that you have found FMSA 9's version of fmserver_helperd did not do this. I have not tried FMSA 10.