7 Replies Latest reply on Sep 28, 2016 12:08 AM by hehazelhorst

    Font color on WebDirect

    andoodle

      Summary

      Font color on WebDirect

      Product

      FileMaker Pro

      Version

      14 & WebDirect

      Operating system version

      Windows 8.1

      Description of the issue

      WebDirect layout had very grayed-out text for each field, rather then the #000 set in the inspector for each state.

      Steps to reproduce the problem

      Place field on layout, set color for states to #000, reload WedDirect page

      Expected result

      Field font should be black

      Actual result

      Font is not black, but #CCC

      Exact text of any error message(s) that appear

      N/A

      Configuration information

      N/A

      Workaround

      WebDirect seems to grab the color from the placeholder instead of the given state. Changing the placeholder font color to #000 solves the issue when viewing.

      1.PNG

        • 1. Re: Font color on WebDirect
          rforgo

          I'm having this issue too. Just noticed it and wondering if it had to do with the Yosemite upgrade I just finished. All black text in WebDirect is now gray and changing the values in the inspector doesn't resolve it.

          • 2. Re: Font color on WebDirect
            TSGal

            Andrei Iancu and Rick Forgo:

            Thank you for your posts.

            I am unable to replicate the issue with FileMaker Pro 14.0.1 under Mac OS X 10.10.3 and Windows 8.1.  Both layouts use the Enlightened theme with one Text field and Text Color set to Black.

            What theme is being used?  Was the field in question copied from another layout/theme?  Does this issue occur in a new layout?  Does this issue occur with a new file?

            What am I doing differently than you so that I can replicate the issue?

            TSGal
            FileMaker, Inc.

            • 3. Re: Font color on WebDirect
              MarcoV

              Getting the same thing here.

              Seems to have happened since Yosemite upgrade. Very annoying as on some machines the user can't read the text. I'm using Tranqil Theme. If I change the object style to Minimal it seems OK, problem is the style isn't good and once you change anything it gets grayed out. Also we've got over 50 layouts with hundreds of text boxes!!

              • 4. Re: Font color on WebDirect
                TSGal

                Marco Vettese:

                I use the Tranquil Theme under Mac OS X 10.10.3, and my Text boxes are displaying correctly.

                What size text are you using?  If you don't change the object style (leave it to default), does it display correctly?  I'm trying to determine if it a font size issue or a style issue.

                TSGal
                FileMaker, Inc.

                • 5. Re: Font color on WebDirect
                  rforgo

                  The workaround we're using is to change the font color from black to the second-darkest gray and NOT save the style or the theme. It seems to be a v13 to v14 bug, or it might be a Yosemite bug. I dunno. But it's as annoying as hell. And it's ruining the concept of saving themes and having everything update application-wide.

                  1 of 1 people found this helpful
                  • 6. Re: Font color on WebDirect
                    blazejay

                    I know that this is an older thread, but I wanted to say we are seeing the same thing in our Windows environment, so I don't think it's (solely) a Yosemite/Mac OS issue.  We recently rolled back to FM 13 Server to provide more stability (and fewer spinning wheels) and found that the style color black on a field, in particular, does not "stick" when updating a style.  (It seemed to be fine in FM 14).

                     

                    Was there ever a solution identified for this?

                    • 7. Re: Font color on WebDirect
                      hehazelhorst

                      I run FM Server 13 on MacOSX 10.8 and it's the same problem on every browser I tried sofar: Windows 7 + IE, Windows 10 + Microsoft Edge, Windows 10 + Google Chrome, OSX 10.9 + Safari, OSX 9 + Google Chrome.

                       

                      Changing themes doesn't solve anything, but changing the font color to #141414 is a work-around (and NOT save it to the theme).

                      1 of 1 people found this helpful