1 Reply Latest reply on Jul 29, 2015 2:40 PM by TSGal

    Format error in calculation editor

    arnoldkegebein

      Summary

      Format error in calculation editor

      Product

      FileMaker Pro

      Version

      14

      Operating system version

      Mac OS 10.10.4

      Description of the issue

      When you add a comment line before a calculation, the font will switch from normal monospace font to bold proportional font.

      Steps to reproduce the problem

      1. Open new calculation editor (e.g. in field definition, script command, …)
      2. Enter a valid calculation
      3. Move cursor to the beginning of the first line of the calculation
      4. Enter a comment and press return
         Both comment types (// and /* */) should work
      --> Font will change

      Expected result

      No font changes

      Actual result

      FOnt changes to bold proportional font

      Exact text of any error message(s) that appear

      n/a

      Configuration information

      FMP14

      Workaround

      Close calculation editor and reopen it

      Screen_Shot_2015-07-28_at_12.02.39.png

        • 1. Re: Format error in calculation editor
          TSGal

          AKegebein:

          Thank you for your post.

          I am unable to replicate the issue.  This is what I have done.

          1. Using FileMaker Pro 14.0.1 under Mac OS X 10.10.4, I created a database file with one Text field "Name".

          2. I went into Script Workspace and created a New Script.

          3. The first line of the script, I entered: If

          4. I went into Specify Calculation and entered: 123 + 456

          5. I moved my cursor to the beginning of the line, entered:   // Comment      and pressed Return.  No change in font.

          6. I created another New Script, entered: If

          7. I went into Specify Calculation and entered: 123 + 456

          8. I saved the script, edited the script, edited the calculation, put my cursor at the top, entered:  // Comment   and pressed Return.  Still no change in font.

          Let me know what I'm doing differently than you so I can replicate the issue:

          TSGal
          FileMaker, Inc.