6 Replies Latest reply on Feb 6, 2009 6:10 AM by wwyngaard

    French Language submitted by xslt

    wwyngaard

      Summary

      French Language submitted by xslt

      Description of the issue

      I have a custom web publishing site running Server version 9 with a Mac Apache web server.On a page there are 2 fields. One for the English version of text the other for the French translation. When the page is submitted the English comes through fine but the French has square characters where there should be accent marks. Is there a way to prevent this. Thanks

        • 1. Re: French Language submitted by xslt
          TSGal

          wwyngaard:

           

          Thank you for your post.

           

          This was reported as a problem and it was fixed.  You can fix this in FileMaker Server 9 by going into the "filemaker-api.php" file and changing the "charset" variable from "utf-8" to "UTF-8" (uppercase).  You should then get the proper coding.

           

          TSGal

          FileMaker, Inc. 

          • 2. Re: French Language submitted by xslt
            wwyngaard
              

            Thanks TSGal but unfortunately this site is xslt as stated in the subject line. I should have put it in the body as well.

             

            We will change this because all of our new sites are php.

             

            Is there something similar for xslt?

            • 3. Re: French Language submitted by xslt
              TSGal

              wwyngaard:

               

              Sorry. I overlooked the title of the post.

               

              I don't have an immediate answer.  I have reported the information to our Development and Software Quality Assurance (Testing) departments for more information.  When I receive a reply, I will let you know.

               

              TSGal

              FileMaker, Inc. 

              • 4. Re: French Language submitted by xslt
                TSGal

                wwyngaard:

                 

                By default, the Admin Console sets UTF-8 encoding for XSLT pages.  Any setting by the developer takes precedence over the Admin Console settings.  The first line on the XSL page should be:

                 

                <xml version="1.0" encoding="UTF-8"?> 

                 

                Also, <xsl: output method="html" encoding="UTF-8"/> should also be set.

                 

                Another place to check for this setting is in the browser.  For FireFox, menu item:

                 

                View -> Character Encoding -> Unicode (UTF-8)

                 

                Is the server in production or development mode?  What browser are you using?  Was the solution developedusing XSLT Site assistant?

                 

                In FileMaker Server 10, there is a FMServer_Sample database that has a French layout with accent characters which shows up fine along with English characters.

                 

                TSGal

                FileMaker, Inc. 

                • 5. Re: French Language submitted by xslt
                  wwyngaard
                     TSGal,

                  Thanks much for the response. Currently our pages are set for ISO-8559-1 and we don't have an input encoding specified.
                  We will change to UTF-8 and test.
                  I will post the results.

                  Thanks
                  • 6. Re: French Language submitted by xslt
                    wwyngaard
                      

                    Thanks very much for your help.

                    Changing to UTF-8 solved the problem.