AnsweredAssumed Answered

Got a "Field is missing" error with cwp after converting fp7 file with fm12v2 but not if doing so...

Question asked by MaximePaquette on Jul 23, 2012
Latest reply on Jul 24, 2012 by MaximePaquette

Summary

Got a "Field is missing" error with cwp after converting fp7 file with fm12v2 but not if doing so with fm12v1

Product

FileMaker Pro

Version

12

Operating system version

Mac 10.7.4

Description of the issue

I tested the conversion of a FileMaker 11 database used with php (FileMaker Server Advanced) using FileMaker 12v1 and everything was working fine.  I did the same thing, but converting with FileMaker 12v2 instead and I got a 102 error (Field is missing) when creating some related records.

In my case, the problem occur in a layout with a portal in it where I create some related records.  I recreated the layout, deleted the fields and putting it back, nothing changed.   After commenting a lot of php line, I think I got something, if the name of the field ( or a word in the name) start with an accented caracter, I got the error...

For example, those lines trigger the error (but only if converted with FileMaker 12.v2, not v1):
  $createPhotoPanier->setField('php_Panier et Archives::Mot de passe Étudiant Chaque Fiche', 'something...');
  $createPhotoPanier->setField('php_Panier et Archives::État', 'Préparation');

but if I change them for this (and change the fields name in FileMaker too), everything work fine:
  $createPhotoPanier->setField('php_Panier et Archives::Mot de passe Etudiant Chaque Fiche', 'something...');
  $createPhotoPanier->setField('php_Panier et Archives::Etat', 'Préparation');

There is no problem if there is an accented caracter inside the name of the field, like this:
  $createPhotoPanier->setField('php_Panier et Archives::Prénom', 'Test');          

I guess it have something to do with encoding or something.  And it probably occur when using a normal record (not a related one).

I just tried it with that particular database and didn't go further, worked all day on this before finding a workaround and had enough for now.  I'll do more test tomorrow.

Expected result

no error

Actual result

error 102

Workaround

Change the field name

Outcomes