9 Replies Latest reply on Dec 4, 2009 6:04 AM by Steve Wright

    Graphics / Native draw objects not displaying

    Steve Wright

      Summary

      Graphics / Native draw objects not displaying

      Description of the issue

      FileMaker Product(s) involved: Filemaker pro 9,Filemaker Pro 10 V1 / V2 / V3Filemaker runtime Operating System(s) involved:Windows XP SP3Windows Vista SP1 Detailed description of the issue:Native drawn objects & graphics do not displayContents of fields cannot be seen until after edittingSome elemenets display without issue.We have now experienced this on over 100 occassions on various client machinesSee video for a first hand look. http://www.sws-solutions.co.uk/beta/filemaker_bug/filemaker_bug.html  Exact steps to reproduce the issue:1.  Unsure of the cause of this... Expected Result:Graphics should display without disabling hardware accelleration Actual Result:Graphics dont display until hardware accelleration is turned down. Exact text of any error message(s) that appeared:N/A Any additional configuration information/troubleshooting that is relevant to the issue:NAAny workarounds that you have found:Turning hardware accelleration down solves the issue temporarily.Please note... out of a wide range of other programs, ONLY filemaker is affected by this. 

        • 1. Re: Graphics / Native draw objects not displaying
          Steve Wright
            

          P.S

           

          The reason the link shows my product and not a basic / empty test database is that I can not reproduce this on my machine
          The only way to show it was via a remote connection to a clients machine which has the issue.

          It is not intended as any form of link to our solution or website

          • 2. Re: Graphics / Native draw objects not displaying
            TSGal

            SW:

             

            Thank you for your post.

             

            What video driver are you using?  What versions?  What type of monitor?  Anything other information you can provide may be helpful.

             

            TSGal

            FileMaker, Inc. 

            • 3. Re: Graphics / Native draw objects not displaying
              Steve Wright
                

              So far there is a variety of machines which shown this error.

              Unfortunatly I cannot give specifics on video card drivers, however I have seen this so far on Intel onboard graphics and a variety of ATI cards

               

              What is interesting is the fact that its only recently started happening, which then poses the question of "what has been updated"

              Unfortunatly (again) I have been unable to replicate it on my own machines, so have only had access via remote connections to investigate on client machines, with limited time to do so.

               

              On each occassion I have checked for recently updated or installed items (if the windows updated / installed dates can be trusted)

              I have also checked for driver updates for the video card's.  Nothing seems to have changed...

               

              I can only assume a windows automatic update may have caused it, however as above, checking the list of recently installed windows updates, none seem to be present in the timeframe this error started.

               

              Other things which may be of interest are :  

              * When the graphics are missing, on some occassions minimizing and maximizing the 'child' window in filemaker can cause them to re-appear

              * Entering Preview mode shows all the graphics.

               

              * Transferring the file to my system, shows everything as normal.

              * Running a recovery on the file shows no errors

              * Creating a new database with native drawn boxes etc also doesnt show the graphics.

              * This should rule out any thoughts of file corruption.

               

               

              From a variety of sources, quicktime came into the conversation, suggesting it may be a cause, however I completely un-installed this on one particular machine as a test followed by a reboot, but it had no effect.

               

               

               

               

               

              • 4. Re: Graphics / Native draw objects not displaying
                Steve Wright
                  

                I had another client with the issue today, so I tried to record more information.

                 

                Machine : Intel Pentium 4 3.0Ghz

                Windows XP Home Edition with Service Pack 3

                 

                Graphics Card : Intel 82915G/GV/910GL Express Chipset

                Driver version 6.14.10.3889 (dated 2004)

                I updated to the latest driver 6.14.10.4764 and rebooted

                 

                Windows update installed KB976098-v2  (seems to be time zone related)

                and KB973687 (seems to be related to http requests)

                These where installed 7 days prior to the issue, no other recent installs.

                 

                Quicktime version 7.6.4 (1327.73)  - 7.6.5 is available for windows so it suggest this was not updated

                 

                I uninstalled Quicktime and rebooted 

                 

                The same problem persisted until I turned down hardware accelleration, this particular machine only required it to be turned down to 'Disable all cursor and advanced drawing accelerations.

                 

                 

                Im still no closer to discovering the actual cause of this, since on this clients machine it was all ok yesterday and has been for about 8 months on the same machine.  It looks like nothing has been updated to cause the issue either but I may be wrong.

                • 5. Re: Graphics / Native draw objects not displaying
                  TSGal

                  SW:

                   

                  Thanks for the additional information.

                   

                  There have been other posts on this forum with people who turn down hardware acceleration to display graphics.  I have a feeling this may be the issue.

                   

                  On my Windows XP SP3 machine, I can display all images, whether it is FileMaker Pro 8.5, 9 or 10, and with any runtime application developed with those versions.  I do not have an accelerator card.

                   

                  In your video, when you slow down the accelerator, I can't help but notice at the top of the screen that displays:

                   

                  "Are you having problems with your graphics hardware?  These settings can help you troubleshoot display-related problems"

                   

                  In any case, I have forwarded the above information to our Development and Software Quality Assurance (Testing) departments for review.  When more information becomes available, I will post again.

                   

                  TSGal

                  FileMaker, Inc. 

                  • 6. Re: Graphics / Native draw objects not displaying
                    Steve Wright
                      

                    I do agree that turning down the accelleration does indeed solve the problem, however this then causes compatibility problems with other software which may use 3d accelleration in some form.  Bearing in mind that absolutely No other programs are affected other than filemaker pro.

                     

                    Its long been known that filemaker has issues when it comes down to windows and screen drawing, all the flicker / screen flash threads make that apparent, however this particular issue is only just surfacing, we have customers who have used our solution for many years without an issue and also customers with fairly new machines.

                    I have only started receiving calls regarding such issues over the last month or so.

                     

                    I realise the windows dialog specifically states if you are having problems with graphics hardware, however on the same note, filemaker gives an error message stating "you cannot share files on this machine since another user is already sharing a file" which is unrelated to the actual problem, turning TCP/IP V6 off can solve it or replacing a certificate file..

                     

                    So simply because something suggestive is written, it doesnt make it the cause of the actual problem.  

                    Is Filemaker a Direct X Accellerated application then if ? Since thats what the window also says the slider position in for.

                     

                    For what its worth, I consider this as a filemaker only issue not a hardware problem.. 

                     

                    P.S > I didnt know you could get a graphics card (addon or built in) these days without some form of direct x accelleration as standard.

                     

                     

                    • 7. Re: Graphics / Native draw objects not displaying
                      TSGal

                      SW:

                       

                      Sorry for the confusion.  I wasn't trying to suggest that the Accelerator Card was the problem.  There is obviously a compatibility problem with FileMaker Pro and the Accelerator Card running at full acceleration.  This information has been forwarded to Development and Testing for further review, and I'll let them work on the problem.

                       

                      However, my comments about the dialog box are valid.  The question I should have posed was why would the dialog box include a statement about graphics related problems?  It seems it was put there for a reason, and I'll let our Testers research it further.

                       

                      Yes, FileMaker Pro has several screen flicker issues with Windows.  This may or may not be related to the Accelerator Card.  Again, I have to defer to Development and Testing.

                       

                      Yes, IPv6 only works with FileMaker Pro 10.  With FileMaker Pro 9, you must use IPv4.

                       

                      When more information becomes available, I will let you know.

                       

                      TSGal

                      FileMaker, Inc. 

                      • 8. Re: Graphics / Native draw objects not displaying
                        Steve Wright
                          

                        No need to apologise TSGal, I re-read my own post and perhaps it came across the wrong way..

                         

                        What I intended was to merely suggest that, messages such as those, do not necessarily reflect upon the true cause of the issue and are merely suggestive at the best of times, its rare these days to see error messages or error codes that point to or describe a single identifiable issue, instead they are somewhat cryptic and generic.

                         

                        I appreciate you forwarding the issue for review.

                        • 9. Re: Graphics / Native draw objects not displaying
                          Steve Wright
                            

                          Another filemaker user on the Filemaker Business Alliance forum (Biztalk) has confirmed this issue presented itself after installing windows updates.

                          However, around 65 updates where installed in one go, since it was the first time it had been connected to the internet.

                           

                          It does appear to be limited to Windows XP, now to find out what updates have been released in the last 3 or 4 months for XP

                          and see if any of them could relate to the issue I suppose.