8 Replies Latest reply on Jan 21, 2009 5:36 AM by pat_pai

    GUI bug with FMP server 9

    pat_pai

      Summary

      GUI bug with FMP server 9

      Description of the issue

      Good day everyone, This is a weird error im geting when using the remote website connectivity link in order to open my GUI server interface. Hope this makes sence, here we go:I'v got FMP SERVER on one box and my PC on another.- I use the Website link approach to the Server using this:       http://ServerName:16000/?page=launch&install=single- And then press the start button- i then get connected to the GUI server manager interface.- And as soon as i press any of the categories on the left hand side like: databases- i get error message: Admin Server Connection error: An unknown error has occured.- and it boots me out of the GUI interface. If i go directly to the server and activate the GUI interface all is well.I only get that when i use the web link approach. And it used to work just fine. Anyone know of a way i could fix this litle problem? Thank you very much.

        • 1. Re: GUI bug with FMP server 9
          TSGal

          patpai:

           

          Thank you for your post.

           

          I cannot duplicate the process.  This is what I have done:

           

          1. I have FileMaker Server 9 running on a Mac.

           

          2. I launch Safari on another Mac and invoke:

          http://<IP Address>:16000/?page=launch&install=single

           

          3. After pressing Start and entering the username and password, I clicked on "Databases" and everything shows fine.  I select any of the other setting without incident.

           

          4. I launch Mozilla Firefox on a Windows XP (SP3) machine and invoke:

          http://<IP Address>:16000/?page=launch&install=single

           

          5. After pressing Start and entering the username and password, I can then click on any of the options on the left side (including Databases) without a problem.

           

          Do you have access to another machine?  If so, can you try this out?  If it doesn't work, then there is some set up on your server probably causing a problem.  If it does work, then your other browser client may have a problem.

           

          Please keep me posted with your progress.

           

          TSGal

          FileMaker, Inc. 

          • 2. Re: GUI bug with FMP server 9
            pat_pai
              

            Alright, thank you very much for taking the time to check this. I will try it from another machine today and see if its still a problem.

             

            I will also try different internet engines to see if it fixes it.

             

            Will keep you posted.

             

            Thanks again.

             

             

            • 3. Re: GUI bug with FMP server 9
              pat_pai
                

              Ok i've tried it on another machine using IE and it works.

              On my machine i've tried with firefox 3, doesnt work.

              Tried re-initializing those Java interfaces by removing them from "Add remove software", still doesnt work.

               

              Any idea as to what is preventing it from working on my machine?

              Anything to do perhaps with my Java being outdated perhaps?

               

               

               

              • 4. Re: GUI bug with FMP server 9
                TSGal

                patpai:

                 

                Thanks for trying this out on another machine.  Although this doesn't solve the problem, it does narrow the choices in half.

                 

                If it works with IE on the other machine, can you try IE on your machine?  If this works, then there appears to be a problem with your FireFox settings.  Firefox is definitely not a problem since I use it here, too.  If IE doesn't work, then it could be a system problem or Java problem.  Make sure you are running Java 6.

                 

                Although I don't believe this to be the problem, be sure to download the SSL Updater for FileMaker Server.  This can be found at:

                 

                http://www.filemaker.com/support/updaters/fms_9.0.3.326_win_update.html

                 

                Keep me posted with your progress.

                 

                TSGal

                FileMaker, Inc. 

                • 5. Re: GUI bug with FMP server 9
                  pat_pai
                    

                  Ok, i've just been retesting my PC setup and i can't get that GUI interface to not buggout.

                   

                  - I've tested with Ie 8 beta and FireFox and i get no results.

                  - Then i installed that update to server that you provided hoping maybe it would  help, but no luck.

                  - Then, i removed anything JAva related to my machine and re-installed it. No luck still.

                   

                  The only thing that works still is from another computer, so obviouslly its something perhaps installed on my machine that is causing this, who knows...

                   

                  Do you have any idea if there's been known issues where certain software could corupt (for lack of better word) the GUI-java interface?

                   

                  thx again for helping me out.....

                   

                  • 6. Re: GUI bug with FMP server 9
                    TSGal

                    patpai:

                     

                    There is obviously something we're overlooking.  Here are the details of my computers:

                     

                    Dell Dimension 4600i running Windows XP SP3, 3.31 GHz 2GB RAM

                    Internet Explorer 7

                    Firefox 3.0.5

                     

                    Java version 6 Update 7 (make sure you don't have something greater.  If so, disable).


                     

                    iMac 24" Mac OS X 10.5.5, 2.4 GHz Intel Core 2 Duo, 2GB RAM

                    Safari 3.2.1

                    Firefox 2.0.0.8

                     

                    Please keep me updated.

                     

                    TSGal

                    FileMaker, Inc. 

                    • 7. Re: GUI bug with FMP server 9
                      pat_pai
                        

                      Ok i see something here...

                       

                      Java:

                      Im running-> JAVA (TM) 6 Update 11

                      So i will try to down grade to 7 like you have to see if this fixes it.

                       

                      I know that everytime i remove Java 6 it would patch me right bck up to update 11.

                       

                      I will keep you posted.

                       

                      • 8. Re: GUI bug with FMP server 9
                        pat_pai
                          

                        Ok good news, its working now.

                        I downloaded the JAVA 6 Update 7 from their web site.

                         

                        I removed all JAVA prior to installing the Exe and did a reboot.

                        I then re-installed that Update 7 and tried it. Works!!

                         

                        So thats what the problem was, the JAVA on my Machine was updated pass the 7 patch.

                         

                        Thank you very much for all your help. :)