8 Replies Latest reply on Mar 26, 2009 1:59 PM by PointInSpace

    Have to restart machine twice to get FMSA to auto-start

    PointInSpace

      Summary

      Have to restart machine twice to get FMSA to auto-start

      Description of the issue

      FileMaker Product(s) involved: FMS10A Operating System(s) involved: OS X 10.4.11 Detailed description of the issue: When the machine is restarted, FMSA doesn't properly auto-start the first time.  It requires another restart of the machine to get it to start. Exact steps to reproduce the issue: Restart machine once, doesn't come up.  Restart again, comes up. Expected Result: FMSA auto-starts Actual Result: FMSA doesn't auto-start on first system restart Exact text of any error message(s) that appeared: Applicable /var/log/system.log lines: Mar  3 09:36:55 localhost launchd: com.filemaker.fms: getgrnam("fmsadmin") failedMar  3 09:36:55 localhost launchd: com.filemaker.fms: exited with exit code: 1Mar  3 09:36:55 localhost launchd: com.filemaker.fms: 9 more failures without living at least 60 seconds will cause job removal  Any additional configuration information/troubleshooting that is relevant to the issue: None - this is a stock OS X Server 10.4.11 install with just FMS10A running. Any workarounds that you have found: Restart machine twice

        • 1. Re: Have to restart machine twice to get FMSA to auto-start
          TSGal

          JohnMay:

           

          Thank you for your post.

           

          I have forwarded your post to our Development and Software Quality Assurance (Testing) departments for review.  I will post again if any information becomes available.

           

          TSGal

          FileMaker, Inc. 

          • 2. Re: Have to restart machine twice to get FMSA to auto-start
            PointInSpace
              

            Thanks!

             

            FYI, I also have a support ticket open and being worked on regarding this and the FMS server stopping issues.

             

            - John

            • 3. Re: Have to restart machine twice to get FMSA to auto-start
              TSGal

              JohnMay:

               

              Our Testers do have some confusion over your post.  I think the answer is known, but they want 100% certainty.

               

              "What does it mean by "not auto-start"?  Does it mean the database is not started?  Or, Web Publishing not started?  Can the customer access "http://localhost:16000"?  Did the customer change Auto Start options under:

              User Account Control -> Configuration > General Settings > Auto Start  tab?"

               

              Thanks.

               

              TSGal

              FileMaker, Inc.

              • 4. Re: Have to restart machine twice to get FMSA to auto-start
                PointInSpace
                  

                It means all of FMSA is not started.  There are no running FMSA processes when I do a ps aux on the command-line.  Not even the watcher process.

                 

                - John

                • 5. Re: Have to restart machine twice to get FMSA to auto-start
                  TSGal

                  JohnMay:

                   

                  Here are some comments and questions posted by Testing:

                   

                  ===========

                   

                  I am unable to reproduce the issue.  What does it mean by "not auto-start"?  Does that mean the database server is not started?  Or, Web Publishing not started?  Is the customer able to access http://localhost:16000 successfully?  Did the customer change the Auto Start options under Configuration > General Settings > Auto Start tab ?

                   

                  Please ask the customer to launch Terminal and issue the command:

                   

                  sudo launchctl start com.filemaker.fms

                   

                  ...and see if it can start FileMaker Server processes correctly.  Make sure the Auto-Start options under Configuration are checked.

                   

                  ===========

                   

                  TSGal

                  FileMaker, Inc. 

                   

                   

                   

                  issue the command “sudo launchctl start com.filemaker.fms” in terminal, and see if it can start FMSA processes correctly? Also make sure the Auto-Start options under Configuration are checked on. -Peter. 

                  • 6. Re: Have to restart machine twice to get FMSA to auto-start
                    PointInSpace
                      

                    None of the FileMaker Server system processes start, no FMS, no WPE processes, not even the watcher daemon. The auto-start preferences are all properly set in the FileMaker Server Admin.  I will try the launchtl command next time I see it happen.

                     

                    FYI, this is also output in the system.log when it doesn't start:

                     

                    Mar 11 13:23:43 localhost launchd: com.filemaker.fms: getgrnam("fmsadmin") failed
                    Mar 11 13:23:43 localhost launchd: com.filemaker.fms: exited with exit code: 1
                    Mar 11 13:23:43 localhost launchd: com.filemaker.fms: 9 more failures without living at least 60 seconds will cause job removal
                     

                     

                    Do note I also have an active case open with tech support regarding this issue.

                     

                    - John


                    • 7. Re: Have to restart machine twice to get FMSA to auto-start
                      TSGal

                      JohnMay:

                       

                      Thanks for the additional information.  It appears the last system.log from Mar 11 is identical to the one you first reported for Mar 3 in your initial post.

                       

                      Thanks for letting me know you had an existing case open, as I have contacted the technician on that case and compared notes.  We are both a bit perplexed, and our only suggestion, to rule out as a possibility, is to uninstall and reinstall FileMaker Server.  We understand that you are hosting files for a number of customers, so uninstalling and reinstalling may not be possible during working hours (or at all).  Is it something you could schedule with your users?  Possibly the weekend?  Just a thought.

                       

                      When you do encounter this again, please do send the log file.  I have sent you a private message (top of this screen - right side - X Messages) with instructions where to send the file.

                       

                      TSGal

                      FileMaker, Inc. 

                      • 8. Re: Have to restart machine twice to get FMSA to auto-start
                        PointInSpace
                          

                        FYI, I did already move everything to a completely separate install, and the same behavior occurs.  Note that it doesn't seem to happen unless I stop FileMaker Server first, then restart.  If I just close all databases then restart *without* stopping FileMaker Server, it all comes up OK on the first reboot.

                         

                        - John