6 Replies Latest reply on May 14, 2012 11:25 AM by sipgrinder

    Help search does not work

    sipgrinder

      Summary

      Help search does not work

      Product

      FileMaker Pro

      Version

      12

      Operating system version

      Mac OS X 10.7

      Description of the issue

      I just installed Filemaker Pro Advanced v 12

      When I select "Help/Filemaker Pro Advanced Help" from the menu and then do any search (i.e. "get ( application version )"), no results are returned and the heading is listed as undefined. see attachment.

      Filemaker_Help.jpg

        • 1. Re: Help search does not work
          TSGal

          sipgrinder:

          Thank you for your post.

          Thank you for the screen shot.  The part next to the FileMaker icon shows "Undefined", when it should display "FileMaker Pro 12 Help".  Somehow, FileMaker Pr is displaying information from another Help file.  Do you have a prior version of FileMaker Pro installed?

          I have included a screenshot of Help from my machine with FileMaker Pro 12.0v1 installed under Mac OS X 10.7.3 and the search results for Get(ApplicationVersion).

          TSGal
          FileMaker, Inc.

          • 2. Re: Help search does not work
            sipgrinder

            I have several different versions of Filemaker:

            Developer 6

            Pro 8.5 Advanced

            Pro 9

            Pro 10 Advanced

            Pro 12 Advanced

            I also had the demo version of Pro 12 that I tried to delete. I was unable to find the preference file even when I went to ~/Library/Preferences/Filemaker Preferences

            • 3. Re: Help search does not work
              TSGal

              slipgrinder:

              Thank you for the information.

              With several versions of FileMaker Pro installed, there is a possibility that the wrong Help file is being called.

              The Preferences file for FileMaker Pro 12 Advanced is located in the following folder (with all the other Preferences files for other versions):

              [User Account] -> Library -> Preferences -> com.filemaker.client.advanced12.plist

              For FileMaker Pro, the file is com.filemaker.client.pro12.plist

              TSGal
              FileMaker, Inc.

              • 4. Re: Help search does not work
                sipgrinder

                It does find the correct help file. As long as I just pick topics, it will take me to the correct information. It is only when I do a search that it does not work. I tried deleting the preference files and that did not help.

                • 5. Re: Help search does not work
                  TSGal

                  sipgrinder:

                  Thanks for the additional information.

                  Try reseetting the Apple Help Viewer.  First, remove the following two Preference files:

                  [User Account] -> Library -> Preferences -> com.apple.help.plist
                  [User Account] -> Library -> Preferences -> com.apple.helpviewer.plist

                  Remove the following files from the Caches folder:

                  [Your user account] -> Library -> Caches -> com.apple.helpd
                  [Your user account] -> Library -> Caches -> com.apple.helpviewer

                  Once removed, launch FileMaker Pro 12 and access Help.  This should write new files based on FileMaker Pro 12.

                  TSGal
                  FileMaker, Inc.

                  • 6. Re: Help search does not work
                    sipgrinder

                    That worked. I had to restart my computer too. Thanks