AnsweredAssumed Answered

Help!  Paragraph Symbol (carriage return) doesn't work in Send Mail Script Step

Question asked by mcward9884 on Aug 6, 2012
Latest reply on Aug 10, 2012 by mcward9884

Summary

Help!  Paragraph Symbol (carriage return) doesn't work in Send Mail Script Step

Product

FileMaker Pro

Version

12

Operating system version

10.6.8

Description of the issue

Since upgrading to 12 and upgrading the operating system, the paragraph symbol doesn't seem to work in the send mail script step.  This hinders not only the "collect addresses across found set" to send to multiple e-mail addresses at once, but also in the body of the e-mail.

The exact same specifications work in a script step for a custom dialog box. 

It just seems to affect the send mail script.

Steps to reproduce the problem

Send Mail [Send via E-mail Client; Message:  "Test" & ¶ & "Test"]

Expected result

Test
Test

Actual result

Test Test

Exact text of any error message(s) that appear

A message appears for the collect addresses across found set when using the script debugger (#3--Command is unavailable, for example, wrong operating system, wrong mode, etc.)

Otherwise, no errors appear for this or for the message body.

Configuration information

This is using Entourage as the e-mail client.

All was working fine with Version 11.

Workaround

I have made my own script to collect addresses across found set, put in a field, and use that field for the "To:" field in the send mail script step. 

A calculation can be used for a field for the "Message:" box, as the paragraph symbol seems to work in calculations, just not in the send mail script.  Although, the field calculation still doesn't work properly for the body of the e-mail, it can at least be copied from the field to the e-mail.

I have not tried to use a different e-mail client.

Has anyone else experienced this, or does anyone have any suggestions?  Thank you.

Outcomes