AnsweredAssumed Answered

HTTPSPOST appears to perform a GET

Question asked by johncampbell on Apr 30, 2014
Latest reply on May 5, 2014 by TSGal

Summary

HTTPSPOST appears to perform a GET

Product

FileMaker Pro

Version

13.0v2

Operating system version

windows 2012 r2 standard

Description of the issue

The response I get from a webserver using an Insert From URL HTTPSPOST does not give the expected result. In fact it appears to be treating the command as a GET. If I do the same thing in .NET. It works ok, code attached.

        private void button1_Click(object sender, EventArgs e)
        {
            textBox3.Text = null;
            textBox4.Text = null;
            Application.DoEvents();
            CPT_Service.CPTO_APIsSoapClient CPTS = new CPT_Service.CPTO_APIsSoapClient();
            // textBox1.Text=493121041
            // textBox2.Text=Spain
            // textBox5.Text=2
            CPT_Service.Output CPTOut = CPTS.GetOutputValue("UJCJHRLFEWAVIAU471GHJ9REJTHWOU36SZSIBNO6", "PHC", textBox1.Text, textBox2.Text, int.Parse(textBox5.Text));
            textBox3.Text = CPTOut.OutputValue;
            textBox4.Text = CPTOut.ErrorText;
        }

Steps to reproduce the problem

When performing an Insert from url using the following:

httpspost://www.dqfactory.com/service/cpto_apis.asmx/GetOutputValue?sApiKey=UJCJHRLFEWAVIAU471GHJ9REJTHWOU36SZSIBNO6&sFunctionCode=PHC&sInputValue=0493121040&sCountry=france&iOptionValue=3

I get:





   

        Runtime Error

       

   



   



Server Error in '/service' Application.




           

Runtime Error





           



            Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

           





            Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".





           


              

                 

              

           


                     




<!-- Web.Config Configuration File -->



<configuration>

    <system.web>

        <customErrors mode="Off"/>

    </system.web>

</configuration>




                 




           




            Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.





           


              

                 

              

           


                     




<!-- Web.Config Configuration File -->



<configuration>

    <system.web>

        <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>

    </system.web>

</configuration>




                 




           




   



Expected result

im expecting a response in this format:

492944000FR+33 (0) 4 929440000

Actual result

see above

Exact text of any error message(s) that appear

see above




Outcomes