2 Replies Latest reply on Mar 18, 2014 3:10 PM by nilsw

    Identical Username/Password specified during Server Setup Causes Errors

    nilsw

      Summary

      Identical Username/Password specified during Server Setup Causes Errors

      Product

      FileMaker Server

      Version

      13

      Operating system version

      Mac OS X 10.8.5

      Description of the issue

      If you provide an identical username and password in setup, the password is not accepted when changing it or the username. Also uploading databases with FileMaker Pro fails due to a password error. This affects only credentials specified during the setup, if you change the password to admin/admin in the console everything works fine.

      Steps to reproduce the problem

      Install FileMaker Server, specify 'admin' as the console username and 'admin' as the password. Try to change username or password later. Try to upload a database with FileMaker Pro.

      Actual result

      * username is not displayed under general settings/admin console/Authentication
      * neither username nor password can be changed
      * databases can't be uploaded

      Exact text of any error message(s) that appear

      password not accepted

        • 1. Re: Identical Username/Password specified during Server Setup Causes Errors
          TSGal

               filemakergarage:

               Thank you for your post.

               I have installed FileMaker Server 13.0v1 on a Mac OS X 10.9.2 server using admin/admin, and I have no issue.  I am able to login, plus I'm able to upload databases to that server using admin/admin.

               Perhaps you could provide me the exact installation steps so I can replicate the issue here.

               TSGal
               FileMaker, Inc.

          • 2. Re: Identical Username/Password specified during Server Setup Causes Errors
            nilsw

                 I had a clean install of FileMaker Server 13, no previous installation of FMS on the machine. I first ran the setup using fmg/fmg as credentials and ran into the issue. When I noticed that a also could not upload databases due to a password error although loggin into the console worked fine, I decided to start from scratch. I deleted the four config files, restarted the adminserver and re-ran the setup, this time using admin/admin but getting the same errors. Running the setup a third time I used my first name as username an some random password. Now the username appeared in the authentication section and I could change both password and username. Also the database upload now worked for the first time. I just wanted to re-run a setup and cover my steps with ScreenFlow but now even admin/admin worked the first time. Maybe someone could test his with a fresh OS installation. The machine is a Mac mini running OS X 10.8.5 and Server 2.2.1.

                 Nils