2 Replies Latest reply on Nov 8, 2012 12:06 AM by Crispin

    If maximum backups is set to 0 then new files are created each backup

    Crispin

      Summary

      If maximum backups is set to 0 then new files are created each backup

      Product

      FileMaker Server

      Version

      12.03

      Operating system version

      OSX 10.7.5

      Description of the issue

      If I set the maximum number of backups to 0 then server seems to write new files even when they have not changed.

      This is a pain as my reason for using this setting is for offsite backups and as a result all the files get sent each time even if I use a backup program that only sends changed files.

      I had even structured the files so that the major unchanged data was all in one file. The system works just fine if I allow more than one copy but then the folder's names are changed with the date and my backup software will see them as new.

      Expected result

      Only changed files show with change date and time

      Actual result

      all files are dated with the backup

      Workaround

      Can't think of one

        • 1. Re: If maximum backups is set to 0 then new files are created each backup
          Markus Schneider

               I'very happy about this feature, I was waiting for years for this!

               - it does NOT create a time stamp

               - it creates a single backup, won't create a set of ie 7 backup-files, it does NOT create a set

               You're in the backup/schedules tab of the server setup, therefore it DOES create a backup, but no timestamps. You can create a schedule and then deactivate that schedule - You can still run this schedule without having to enable it

               (-:

          • 2. Re: If maximum backups is set to 0 then new files are created each backup
            Crispin

                 I'm not certain I understand Marcus's comment but I wonder if he understands my post - I expect this is my failing to explain well!

                 I do very much like the 0 setting and that it stops the folder with the backup being renamed. My problem is that unchanged files are not left as they are as happens with the hard linked files of the multi-backups that are unchanged but instead seem to be rewritten with new files with a modification timestamp on the file iteslf that matches the time of the backup.

                 Today is the 8th November. In the attached grab the backup at the top (multi setting) was done today straight after the one at the bottom (zero setting). It reveals that two of the files have not been modified since 8 pm yesterday and one has not been modified for 9 days. The bottom schedule has been run many times during that period. Each time all files are shown as newly written.