AnsweredAssumed Answered

If the edit toolbar is disabled, the layout does not scroll properly when the keyboard pops up.

Question asked by ltwimberly on May 13, 2015
Latest reply on Jul 14, 2015 by philmodjunk

Summary

If the edit toolbar is disabled, the layout does not scroll properly when the keyboard pops up.

Product

FileMaker Go

Version

14

Operating system version

iOS 8.3

Description of the issue

If the edit toolbar is disabled on FM Go and you enter a field in the lower portion of the layout where the keyboard appears, the layout doesn't scroll up in the normal manner. Instead the keyboard covers the lower portion of the layout, obscuring it. Once the keyboard is dismissed, a white translucent rectangle persists where the keyboard was. In some cases, when a field in this lower portion is entered, the keyboard repeatedly pops back up despite being dismissed.

Steps to reproduce the problem

Put a text field at the bottom of a layout.

Disable the edit toolbars via a script.

Enter the text field.

Expected result

The layout should scroll up so that the bottom of the layout is flush with the top of the keyboard, allowing the user to see the field where data is being entered.

Actual result

The layout doesn't scroll up, so the keyboard obscures the lower portion of the layout.

Exact text of any error message(s) that appear

None

Configuration information

I have only tested this on the iPad. It happens in both landscape and portrait mode.

I tried specifying "System Default" and "Default for Data Type" for the Touch keyboard type for these fields and it made no difference. I didn't try any of the other options since the bug appears to be related to disabling the edit toolbar.

Workaround

Everything behaves as expected if the edit toolbar is turned on.

Outcomes