0 Replies Latest reply on Oct 17, 2012 9:22 PM by Malcolm

    Import Field mapping is lost when I select or deselect on Don't Import First Record

    Malcolm

      Summary

      Import Field mapping is lost when I select or deselect on Don't Import First Record

      Product

      FileMaker Pro

      Version

      12.0v2

      Operating system version

      OSX 10.6.8

      Description of the issue

      The field mapping is lost each time I select Don't Import First Record.

      Steps to reproduce the problem

      Select Import Records -> File...
      Select a file. I chose a CSV file.
      Align the fields in the correct order. I chose "creation order".
      Ensure that each one is set to import.
      In this case, most fields were not set to import.
      I do this by clicking on a field at the top then shift-clicking on a field at the bottom. The dialog displays a small arrow -> between the field names.
      Select "Don't Import First Record"

      Expected result

      I expect my field import settings to remain in place when I select the checkbox.

      Actual result

      All but the first field I clicked on are deselected for import. The import settings are changed. The first time the arrow changed to two dots. The next time the arrow changed to a double-headed arrow.

      Workaround

      make the selection for First Row prior to aligning and mapping fields

      ImportProblems.gif