AnsweredAssumed Answered

Import of a large CSV file halts after 4GB

Question asked by StanHerrin on Apr 28, 2011
Latest reply on Jan 19, 2012 by TSGal

Summary

Import of a large CSV file halts after 4GB

Product

FileMaker Pro

Version

11

Operating system version

Mac 10.6

Description of the issue

I am trying to import five very large .csv files--each one is about 42GB. On the two files I've tried so far, Filemaker imports about 4 GB worth of data--about 1.2 million records--then stops.

Steps to reproduce the problem

import the file

Expected result

Filemaker should import about 11 million records

Actual result

Imports only about 1.1 million records

Exact text of any error message(s) that appear

no error messages appear. The message is that the import went fine with no skips.

Configuration information

This is a very wide file--2000 or so fields. However, I have tried just importing one field at a time and I get the same result.

I have a 2.8 GHz MacBook Pro with 4 GB of Ram, running 10.6.7. Is import file size limited to RAM size?

Workaround

have not found any.

Outcomes