AnsweredAssumed Answered

Import script error when hosted on FMS

Question asked by duaneweller on Feb 17, 2012
Latest reply on Mar 9, 2017 by binu.alexander

Summary

Import script error when hosted on FMS

Product

FileMaker Server

Version

11.0.4.404

Operating system version

Mac OS X 10.7.3

Description of the issue

When performing a scripted import on a hosted file a "No fields were selected for import" error is displayed when "matching" is chosen as the import order. Same script and file combination work fine when file is opened locally.

Steps to reproduce the problem

Create a new file. Import a CSV file. Create a script. Add "Import Records" script step. Check "Perform without dialog" and "Specify import order". Leave "Specify data source" unchecked. Set "Arrange by" to "matching names". CSV file should include the field names in the first record. Test the script. It should work fine locally. Now host the file with FMS on Mac OSX. Open the file with Open Remote. Run the script selecting your CSV file for import.

Expected result

The CSV file should import while the file is hosted.

Actual result

A "No fields were selected for import" error is displayed.

Exact text of any error message(s) that appear

"No fields were selected for import"

Configuration information

Client is FileMaker Pro Advanced 11.0v4 running on Mac OSX 10.7.3.

Workaround

1) Uncheck "Perform without dialog" and require the user to set the import order manually. 2) Set the import order to "last order" after importing using "matching names".

Screen_Shot_2012-02-17_at_11.29.59_AM.png

Outcomes