1 Reply Latest reply on Mar 3, 2009 2:42 PM by TSGal

    Import with Matching Field Names Doesn't Remember

    ssmithh

      Summary

      Import with Matching Field Names Doesn't Remember

      Description of the issue

      My script imports a tab-delim file, set to no dialog, no file specified(so user has to select a file to import).  I'd set the import order bytemporarily specifying a sample file, with the first row set to befield names, setting it as matching fields (which is allowed and itworks).  I then unmark the filename specifier so the user will be askednext time.  Shouldn't my import order be saved?  When I run the scriptand specify the same exact text file, I get a message that there are nofields set in the import order.  Huh?  And when running the scriptagain (this time not hiding the dialog), I get to the import mappingscreen and 'matching fields' is grayed out. (FM9)

        • 1. Re: Import with Matching Field Names Doesn't Remember
          TSGal

          ssmithh:

           

          Thank you for your post.

           

          Did you save the script initially with the field order?  Or, did you select the file, the field order and then unchecked the option?

           

          This is what I did:

           

          I created a script with one script step:

           

          Import Records []

           

          I included a sample file, included the field matching, and saved the script.  Then, I went back into the script and removed the file reference.

           

          Now, when I run the script, I select a similar file, and the field names match appropriately.

           

          TSGal

          FileMaker, Inc.