12 Replies Latest reply on Apr 19, 2016 11:37 AM by schamblee

    Insert from Device camera second time has black screen

    schamblee

      Summary

      Insert from Device camera second time has black screen

      Product

      FileMaker Go

      Version

      13.0.8

      Operating system version

      ios8.1.2

      Description of the issue

      Replacing container picture with new picture using insert from Device camera the screen will be black. It will still make picture but you can not see the picture on screen.  If you can take a  picture a 3rd time and it works, again a 4th time it black again.

      Steps to reproduce the problem

      Create a container take picture with insert from device camera, use picture then repeat to insert a new picture into the same container and the second time the camera screen will be black.

      Expected result

      No black screen, see the picture I'm taking on screen.

      Actual result

      A black screen and no idea what picture is being made.

      Exact text of any error message(s) that appear

      No text or error message just a black screen.

      Configuration information

      iPhone 5, Test DB created in FMPA 13.0.4

      Workaround

      Take picture again.  It doesn't lockup it just appear that you can't replace the picture because the screen is black.

        • 1. Re: Insert from Device camera second time has black screen
          TSGal

          S Chamblee:

          Thank you for your post.

          I am unable to replicate the issue.  This is what I have done:

          1. Using FileMaker Pro 13.0v4 under Mac OS X 10.10.1, I created a database file "SChamblee.fmp12" with two fields:
             Name (Text)
             Picture (Container)

          2. I created a script named "Insert From Device" with the following script step:
             Insert from Device [ SChamblee::Picture ; Type: Camera: Back ; Resolution: Full ]

          3. In Browse Mode, I added one record and entered into the Name field "TSGal".

          4. I closed the file, and transferred it to my iPad running iOS 8.1.2.

          5. I launched FileMaker Go 13.0v8, opened SChamblee.fmp12, and executed the script "Insert From Device".

          6. I took a picture, and tapped "Use Photo".  The Picture field displays the photo I just took.

          7. I executed the script again, took a picture, tapped "Use Photo", and the Picture field displays the new photo.

          8. I repeated this several times without any issues.

          9. I went back to the original file in FileMaker Pro, and changed the Insert from Device script step to use the front camera.  No change.

          Let me know what I'm doing differently than you so I can replicate the issue.

          TSGal
          FileMaker, Inc.

          • 2. Re: Insert from Device camera second time has black screen
            schamblee

            I get the same results on my ipad and iphone. Here is a sample database  https://www.dropbox.com/s/yhnmst2bjrwu1sj/TestContainer.fmp12?dl=0

            I take picture, then click use, and the photo show as expected.  Click to take picture again on same record and field, then camera comes up black, you can still take picture but camera viewer is black.  It occurs about every other time you go to take picture.

            • 3. Re: Insert from Device camera second time has black screen
              TSGal

              S Chamblee:

              Using your file, I am still unable to replicate the issue.  I can continually take a different picture and use it over in the single record.

              Exit FileMaker Go, launch FileMaker Go, open the file, and try again.  If this still fails, then reboot your iOS device and try again.  If this still fails, then reinstall FileMaker Go.

              TSGal
              FileMaker, Inc.

              • 4. Re: Insert from Device camera second time has black screen
                schamblee

                I'm getting the same results on two different devices. I have an iPhone 5 and iPad 3. The iPad was turned off and then I power on and copy the test database to it.  Click Take Pic, camera comes up and view finder is normal (most of the time), take picture, click use.  Click Take Pic again from inside the database and the camera comes up with a black screen.  I can still take picture but the view finder is black. The picture is insert into the container.  I made a quick video from my iphone of my ipad. Notice the second time I press the take pic button from inside the database it goes to the camera with a black screen.  I still take picture, but there is nothing in the view finder when I take the picture, it black. https://www.dropbox.com/s/8lr6f2z7k8v5hp7/My%20Movie%209.mp4?dl=0

                Notice at around 13 seconds into video that the cameras view finder is black with only the camera button, which does still take picture correctly.  You just don't know what of because the view finder is black.  This occurs on both devices.

                • 5. Re: Insert from Device camera second time has black screen
                  TSGal

                  S Chamblee:

                  Thank you for the movie, but I am still unable to reproduce the issue on an iPhone 5s (I don't have access to an iPhone 5) and an iPad 3.  I also tested on an iPhone 6, iPad Air, and iPad Mini; at least 8-10 pictures taken on each device using your sample database.

                  I have tried different system settings, but I am still unable to replicate.

                  Has anybody else run into this issue?

                  TSGal
                  FileMaker, Inc.

                  • 6. Re: Insert from Device camera second time has black screen
                    schamblee

                    I removed Go from my iphone 5 and reinstalled, and still have the same issue and as I stated earlier in my post it is happening on both devices, regularly.

                    • 7. Re: Insert from Device camera second time has black screen
                      schamblee

                      I have  an iPhone 6 and the issue is easily reproduced on it just like it was on the other devices.   I have tested  with different databases and two different iPhones and an iPad, no hit or miss on reproducing the issue. It occurs all the time.  It must be the weather in Alabama that is causing the problem, because it has happened on every devices with multiple databases.

                      Devices I have tested: iPad 3, iPhone 5, and iPhone 6 and all with the same results.

                      Steps to reproduce issue

                      Take a picture with the script step insert from device camera, use the picture and then retake picture again.  Usually the second time when the camera is activated the view finder is black. You can still make picture but you can not see what you are making a picture of because the view finder is black.

                      • 8. Re: Insert from Device camera second time has black screen
                        TSGal

                        S Chamblee:

                        I am still unable to replicate the issue on an iPhone 5s, iPhone 6, and an iPad 3.  I used the same steps as above on a similar file.

                        Do you have any Restrictions set on your iPad?  That is, go to Settings -> General -> Restrictions

                        Send a copy of your database file, and I will try it here.  Check your Inbox at the top of this page for instructions where to send the file.

                        TSGal
                        FileMaker, Inc.

                        • 9. Re: Insert from Device camera second time has black screen
                          schamblee

                          No restrictions are set.  I don't know why you can't reproduce the problem, every time I tested the issue it appears.  It appears usually the second time you take the picture, to replace a picture in the current container that a picture was just insert from the camera.  I just got my iPhone 6 last week and all the files were restored from the cloud, I tested the databases on the new phone and the issue appears.  Repeat taking picture using the same record / same container field.

                          • 10. Re: Insert from Device camera second time has black screen
                            mclemens

                            Hi,

                            i think that i get the solution: I had the same problem like the others und configured a "new" second iPad. There was no "every second photo missed the lifeview bug". So i compared the Filemaker-Settings, but everything was fine. Then i compared the iOS-Settings. And under: Settings/Accessibility/Speech the "Speak Selection" und the "Speak Screen" was activated. I switched them off - AND - Now it works ... Hope it will help for all with the same problem.

                            Bye Matthias

                            PS: Sorry for my English =;-))

                            • 11. Re: Insert from Device camera second time has black screen
                              CyrilLevi

                              Hi, I had the same issue but was able to fix it.

                               

                              Go to Settings > Scroll through the applications to Filemaker Go > Click on Filemaker Go > Under "ALLOW FILEMAKER GO TO ACCESS", enable the Camera and restart the iPad.

                               

                              This worked for me

                              • 12. Re: Insert from Device camera second time has black screen
                                schamblee

                                No, that was not the issue.  

                                 

                                When access has not been granted, no pictures would be displayed, you would get a black screen all the every time.   Apparently the issue was fix in one of the updates.