AnsweredAssumed Answered

Insert From URL fails with error 10 for some data sets

Question asked by nickorr on Feb 5, 2014
Latest reply on Aug 9, 2017 by FabriceNordmann

Summary

Insert From URL fails with error 10 for some data sets

Product

FileMaker Pro

Version

13v1

Operating system version

Mac OS X 10.9.1

Description of the issue

I had a system using httppost in the InsertFromURL script step that was working fine.  I changed one aspect of the path in the url from /RESTfm/ to /RESTfm.dev/ and when I do that, InsertFromURL  throws an error 10 and doesn't submit the data.

Steps to reproduce the problem

Create a new file with two fields, URL and result, and a script to run the InsertFromURL step, and capture the error.  By just adjusting the url slightly you can get an error in what should per a perfectly valid url.

Expected result

There is nothing wrong with the url, it shouldn't throw any errors.

Actual result

I get error 10.

I've also seen, but been unable to repeat in a clean file, a situation where I got error 507 ( Value in field failed calculation test of validation entry option ) in spite of the fact that not a single field in the entire solution used validation, let alone calc validation.  When I tried to recreate this one in a test file it failed.

Exact text of any error message(s) that appear

error 10

Configuration information

The URL in questions are in a sample file I can provide if required.

Workaround

None available, there is no way to tell a real error from this false one.

Outcomes