6 Replies Latest reply on Aug 9, 2017 1:40 AM by FabriceNordmann

    Insert From URL fails with error 10 for some data sets

    nickorr

      Summary

      Insert From URL fails with error 10 for some data sets

      Product

      FileMaker Pro

      Version

      13v1

      Operating system version

      Mac OS X 10.9.1

      Description of the issue

      I had a system using httppost in the InsertFromURL script step that was working fine.  I changed one aspect of the path in the url from /RESTfm/ to /RESTfm.dev/ and when I do that, InsertFromURL  throws an error 10 and doesn't submit the data.

      Steps to reproduce the problem

      Create a new file with two fields, URL and result, and a script to run the InsertFromURL step, and capture the error.  By just adjusting the url slightly you can get an error in what should per a perfectly valid url.

      Expected result

      There is nothing wrong with the url, it shouldn't throw any errors.

      Actual result

      I get error 10.

      I've also seen, but been unable to repeat in a clean file, a situation where I got error 507 ( Value in field failed calculation test of validation entry option ) in spite of the fact that not a single field in the entire solution used validation, let alone calc validation.  When I tried to recreate this one in a test file it failed.

      Exact text of any error message(s) that appear

      error 10

      Configuration information

      The URL in questions are in a sample file I can provide if required.

      Workaround

      None available, there is no way to tell a real error from this false one.

        • 1. Re: Insert From URL fails with error 10 for some data sets
          TSGal

               Nicholas Orr:

               Thank you for your post.

               These type of issues are difficult to replicate, since a new file does not have this issue.  Whenever I change the URL's slightly, I get a redirect to a 404 default page.  The only time I get the 507 error is when I do have a field validation failure.  I know this doesn't help you, but I'll need to try a few things to maybe narrow down why this occurs with your file.

               Is the Insert from URL referencing a hard-coded web page?  Or, are you referencing a field?  If the former, try creating a new script with the same URL script step.  If the latter,  create a new field with the URL value and reference the new field in the Insert from URL script step.  If either method still fails, try running a Recover on the file.  Open the recovered file and see if the same issue occurs.

               Any other information you can provide may help m replicate the issue..

               TSGal
               FileMaker, Inc.

          • 2. Re: Insert From URL fails with error 10 for some data sets
            nickorr

                 TSGal,

                 This one is easy to replicate, I've created it in a new file.  Can I send you the file?  It has two records, one for a good url and one for a bad url.  The only difference being the addition of four extra characters in the path.  I just didn't want to post the urls publicly.

                 Cheers,

                 Nick

                  

            • 3. Re: Insert From URL fails with error 10 for some data sets
              TSGal

                   Nicholas Orr:

                   By all means, send the sample file.  Check your Inbox at the top of this page for instructions where to send the file.

                   TSGal
                   FileMaker, Inc.

              • 4. Re: Insert From URL fails with error 10 for some data sets
                nickorr

                     TSGal,

                     I've been thinking about this one, and I think there is still an error or bug that could be resolved.  The issue is that the step doesn't return any data, even though the url call does.

                     So when you run a tcpdump while sending this, the server returns data.  That data contains the details of the error ( 500 ) and some other details that are useful to diagnose the issue.

                     The bug is that FileMaker should put this data into the field, as well as returning the error code.  That would make it much clearer as to what is happening.

                     It would also be very handy to get a list of the potential error codes that this step could return, perhaps this could be added to the documentation.  Like I've mentioned, I've also got a 507 error back in a file that doesn't use validation, and I'm still trying to figure out why.  I'll submit a separate report once I figure that out.

                     Is it worth adding a new report to say that when you get error 10 you don't get any of the error details, or will this report suffice?

                     Cheers,

                     Nick

                • 5. Re: Insert From URL fails with error 10 for some data sets
                  nickorr

                       TSGal,

                       I will submit a new bug report, as I found another place it's not reporting error details.  So close this one and I'll start anew.

                       Thanks,

                       Nick

                  • 6. Re: Insert From URL fails with error 10 for some data sets
                    FabriceNordmann

                    Nicholas, did you by chance find a work around in the mean time?