5 Replies Latest reply on Jul 22, 2014 10:36 AM by TSGal

    Insert From URL returns bogus "Validation" errors for some urls

    nickorr

      Summary

      Insert From URL returns bogus "Validation" errors for some urls

      Product

      FileMaker Pro

      Version

      12.0v3

      Operating system version

      Mac OS 10.8.2

      Description of the issue

      When doing Insert From URL, FileMaker is returning an error 507 for some URLs.  For example, using the script step, put in this url :

      https://Admin:Admin@fms12.goya.com.au/RESTfm/RESTfmSync/layout/SampleTable.RESTfm/49.simple?Field5=kwf&RFMmethod=PUTAdmin@fms12.goya.com.au/RESTfm/RESTfmSync/layout/SampleTable.RESTfm/49.simple?Field5=kwf&RFMmethod=PUT

      FileMaker will not send the url and gives a 507 error.  However append a & on the end to :

      https://Admin:Admin@fms12.goya.com.au/RESTfm/RESTfmSync/layout/SampleTable.RESTfm/49.simple?Field5=kwf&RFMmethod=PUT&Admin@fms12.goya.com.au/RESTfm/RESTfmSync/layout/SampleTable.RESTfm/49.simple?Field5=kwf&RFMmethod=PUT&

      and it works fine.  I can't see how this is in anyway a more valid url, and the error seems to be related to field validation ( of which this field has none ) and not url validation.  However, either way it shouldn't cause this error

      Steps to reproduce the problem

      Create a new file with a single text field.  Add a script to do Insert From URL to the new field and use this url :

      https://Admin:Admin@fms12.goya.com.au/RESTfm/RESTfmSync/layout/SampleTable.RESTfm/49.simple?Field5=kwf&RFMmethod=PUTAdmin@fms12.goya.com.au/RESTfm/RESTfmSync/layout/SampleTable.RESTfm/49.simple?Field5=kwf&RFMmethod=PUT

      Run the script in the debugger, and check the last error code on that script step.

      Expected result

      There is no way this url should cause an error when the same url with & on the end doesn't.

      Actual result

      error 507.

      Configuration information

      NA

      Workaround

      Appending & can resolve it in this situation, but because you can't tell that there is anything wrong with the url in the first place, I've no idea if this issue is just related to something about the url, or if it will occur in other ways for other urls.  This leaves me no confidence in the script step and it's ability to work reliably in the future.

        • 1. Re: Insert From URL returns bogus "Validation" errors for some urls
          nickorr

               Actually I have some more detail on this.  It turns out the url is being sent to the server, and it's not a validation issue.  However in this case, the server is returning a result code of 204, which is technically ok, and shouldn't cause an issue.  The end result should be that the FileMaker field is emptied and no error returned.

                

                

               Cheers,
               Nick
          • 2. Re: Insert From URL returns bogus "Validation" errors for some urls
            danshockley

                 No response from FileMaker? That's disappointing. The Insert From URL script step shouldn't pick a random error message when a non-error response is sent back from a web service. These kinds of bugs in Insert From URL are troubling. 

            • 3. Re: Insert From URL returns bogus "Validation" errors for some urls
              TSGal

                   NIcholas Orr and DanShockley:

                   Thank you for your posts.

                   My apologies for the late reply.  This thread slipped through the cracks, and if it wasn't for DanShockley bringing this to the forefront again, this thread would have been buried/lost.

                   I just tried the link in the Insert from URL script step, and I receive a Connection failed.error message.  I know this post is four months old, and the link is probably outdated.  Can you make the link active again (or provide a new link) so I can test it and send it to the appropriate departments?

                   TSGal
                   FileMaker, Inc.

              • 4. Re: Insert From URL returns bogus "Validation" errors for some urls
                nickorr

                     TSGal,

                     I've tried to conjure up a url that throws this error, and I can't any more.  I don't know if something has changed in FMPA or if there was some difference between the original one and the new ones I've created.

                     There's another similar report here : http://forums.filemaker.com/posts/14645b2381  Can you confirm if there's been any change to that bug?

                     I still think this is a serious issue, in that it's reporting a validation error number when there is no validation involved.

                     Cheers,

                     Nick

                • 5. Re: Insert From URL returns bogus "Validation" errors for some urls
                  TSGal

                       Nicholas Orr:

                       The issue reported in the other link is not referenced by any change in FileMaker Pro.

                       I understand you can no longer reproduce the 507 error, but I am subscribed to this thread, so when you run into error again, please let me know, either through this post or a new post.

                       TSGal
                       FileMaker, Inc.