3 Replies Latest reply on Jul 2, 2015 2:11 PM by TSGal

    Inspector check box options are wrong for the "do not apply visual spell checking" behavior

    Malcolm

      Summary

      Inspector check box options are wrong for the "do not apply visual spell checking" behavior

      Product

      FileMaker Pro

      Version

      14.0.1 , 13.0.9

      Operating system version

      Mac OS X 10.9.5

      Description of the issue

      When setting the behaviour of a field the "do not apply visual spell-checking" checkbox cycles through three options when there are only two options.

      There should only be On/Off but a third option is displayed.

      The third option is a hyphen, normally used to describe a an array of objects with mixed states.

      If the third option is selected, it is not honoured, the state that is preserved is "on".

      Steps to reproduce the problem

      In layout mode, select a field, open the inspector and select the "Data" tab.

      Using the mouse, click the  "do not apply visual spell-checking" checkbox repeatedly.

      Try leaving the checkbox in the hyphen state. Select another object momentarily, then select the field again. You'll see that the checkbox does not display a hyphen.

      Expected result

      The checkbox should not cycle through the third option. Only two options should be presented.

      Actual result

      A third state is presented to the user.

      Exact text of any error message(s) that appear

      none

      Configuration information

      not applicable

      Workaround

      1. Select the correct object state