2 Replies Latest reply on Apr 8, 2011 7:11 AM by FredMeyer

    Invisible Arial Font

    FredMeyer

      Summary

      Invisible Arial Font

      Product

      FileMaker Pro

      Version

      11.0v1

      Operating system version

      Mac OS 10.6.7

      Description of the issue

      I installed Filemaker on a brand iMac.  Running files from the Filemaker Training Series DVD, I found that any field or layout object using Arial was invisible. I found that on my own FMP files, I could cure the problem by switching to another font.

      To cure based on various forum articles I found, I removed all Arial fonts from the computer. Yet, Filemaker still shows an Arial font available in Format/Fonts...

      Using a different user account (one existing, the other created for this test), Filemaker would open the same files and a font appeared as expected....presumably not Arial, since it'd been removed.  Problem gone, and Arial gone from Format/Fonts.

      However, the main user account still has the problem, and Arial continues to show in Format/Fonts menu.

      Appears obviously related to a user account, but since being removed, there are no arial fonts in the System or user Library. Yet....Filemaker is still finding Arial somewhere, and it won't display.

      Steps to reproduce the problem

      See above

      Expected result

      see above

      Actual result

      see above

      Exact text of any error message(s) that appear

      No error messages

      Workaround

      None found

      Screen_shot_2011-04-05_at_8.14.44_PM.png

        • 1. Re: Invisible Arial Font

          Fred Meyer:

          Thanks for posting!

          Since we know it's a user issue, let's try moving all fonts from the user font folder, instead of just Arial. Open /Users/<your username>/Library/Fonts/ in finder and move all of these fonts to a folder on your desktop. Then, launch FileMaker again and let us know if it still gives you this issue.

          TSBear

          FileMaker, Inc.

          • 2. Re: Invisible Arial Font
            FredMeyer

            TSBEar, thanks.

            Tried it.

            Removed all fonts to a folder on desktop, from Users/<username>/Library/Fonts

            No change. Filemaker wasn't getting fonts from there. 

            Then I removed all fonts to a folder on the desktop, from System/Library/Fonts

            This changed things....but now Filemaker sees a very limited number of fonts...including Arial.

            Finder search for some of those fonts finds only font suitcases with those names in a Microsoft Office folder. 

            Finder search for "Arial" returns only fonts that are in "disabled" folders on the desktop.

            So, Filemaker is finding fonts somewhere else!

            I had also found (and trashed) a very old file from years ago, "FM Pro Fonts". I recall v.2 or 3 used to get fonts from this file.

            So, still not solved!