4 Replies Latest reply on Oct 27, 2011 1:33 PM by GaryTaustine

    Invisible text

    StevenKaleita

      Summary

      Invisible text

      Product

      FileMaker Pro

      Version

      8.5 & 11

      Operating system version

      OS X 10.5 & 10.6  Intel based Macbook Pro

      Description of the issue

      In All the starter solutions,all  the text is invisible. I tried changing the color, but the only thing that works is to change the font to something other then Ariel & Verdana. These two fonts are system fonts, they are installed and check out to be OK according to Fontbook &  Font Doctor.

      When I run Filemaker Pro 8.5 or 11, on my G5 power pc based system, using the starter solutions, the text displays as it should.

      Steps to reproduce the problem

      Select a starter solution.

      Expected result

      I should be able to see the text.

      Actual result

      No text is visible.

      Exact text of any error message(s) that appear

      None

      Configuration information

      MacBook Pro intel based 2.4 ghz Snow Lepoard & Lepoard.

      Works as expected on my Power pc G5 2.5 dp.

      Workaround

      go to layout mode, go to edit menu, select all, go to font menu, choose another font.

      You have to do this to every layout in the database.

        • 1. Re: Invisible text
          TSGal

          Steven Kaleita:

          Thank you for your post.

          I use FileMaker Pro 11 on a MacBook Pro running under Mac OS X 10.6.5, and all starter solutions display properly, and although this doesn't necessarily help you, it lets me know the Starter Solutions are fine on a similar setup.

          In case some user system preferences are damaged, create a new user account on your MacBook Pro, log in to the new user account and launch FileMaker Pro.  Try using one of the Starter Solutions and see if you run into the same problem.

          FileMaker Pro uses the system fonts, so since this isn't working for you, let's assume FileMaker Pro was not installed properly.  Uninstall and reinstall.  If this still fails, try removing the Arial and Verdana fonts from your system, and then reinstall them from your Mac OS X system disk.

          Please keep me updated with any progress.

          TSGal
          FileMaker, Inc.

          • 2. Re: Invisible text
            test2

            TSGal

            I have the same problem as Steven and as you suggest the problems seems to be related to the user account since everything shows up fine when using a new account on the same computer. I tried the install/uninstall but with no success. Could you please tell me which preference files and their locations that need to be deleted (since they remain behind after the uninstall process)?

            Kind regards,

            Louis

            • 3. Re: Invisible text
              TSGal

              test2:

              Thank you for your post, and I apologize for the late reply.

              If the new user account is fine, then start by removing the preferences file from:

              User Account -> Library -> Preferences -> com.filemaker.xxxxxx.plist

              ("xxxxx" will either have "pro", "pro.advanced", or something similar)

              Also, run Disk Utility (Hard Drive -> Applications -> Utilities -> Disk Utility).  Select the hard disk and repair disk permissions.

              If you already resolved the problem, please post here so others can possibly benefit from your solution.

              TSGal
              FileMaker, Inc.

              • 4. Re: Invisible text
                GaryTaustine

                I had the same problem, and after trying all of the available solutions posted here and elsewhere I finally cracked it. 

                This is for Mac OS X only.

                Open a database with invisible text, then select all contents of a field where the text is invisible.

                Check which font it is by right-clicking on the selected text and locating the current font in the font menu.

                Quit Filemaker Pro

                Open FontBook in the Applications folder, make sure "All Fonts" is selected in the "Collections" column, and find that font. There will most likely be two or more versions of the font, and one or more may be disabled.

                Right-click on each of them, one at a time, and select "Show in Finder" from the menu. Each one will open a different folder. 

                One of those folders will be (Hard Drive -> Users -> yourcomputername -> Library -> Fonts. *hint* You can check the path by holding down the COMMAND key then clicking on the word "Fonts" in the window title.

                That's the important folder, find your font.  Then look in the other folders and find the one with the most recent creation date.

                Replace the font in  Hard Drive -> Users -> yourcomputername -> Library -> Fonts, with the most recent one.

                Now go back to FontBook and disable all versions of your font (by right clicking and selecting "Disable" from the menu) except for the one in  (Hard Drive -> Users -> yourcomputername -> Library -> Fonts. Make sure that one is the only enabled version.

                Now, open up your database.

                Hope it worked for you.