1 Reply Latest reply on Apr 3, 2015 10:22 AM by TSGal

    Issue for displaying images stored externally using instant web publishing

    JuanSebastianRodriguez

      Summary

      Issue for displaying images stored externally using instant web publishing

      Product

      FileMaker Server

      Version

      12

      Operating system version

      Windows 7

      Description of the issue

      I'm using a Filemaker Server 12 for hosting a database which has some container fields for images. In order to avoid to have a huge database file in the future, I've decided to store externally the images, and modify the containers accordingly. There are no problems when I use Filemaker pro 12 or 13 for opening the database. But when I use Instant Web Publishing through Filemaker Server 12, I see a missing image icon instead of the picture. It is the same in Firefox, Chrome and Windows Explorer. I've check the data in the RC_Data_FMS folder of Filemaker Server and the pictures are correctly stored from the original location. I also have compared the URL image locations in the web browser when I open the database in Instant Web Publishing in 2 cases:
      1) The database with embedded images
      2) The database with externally stored data.
      In the first case the image opens without any problem, the URL looks like this: 128.178.180.207/fmi/iwp/data.png?-containerfield&-recid=1&-field=4(1).1
      In the second case, I'm redirected to the dabase homepage, the image is never displayed. The URL looks like this: 128.178.180.207/fmi/iwp/Public/VPLibrary/Containers/Symbols/1.png

      Could someone help me to solve this problem? I've tried everything.

      Steps to reproduce the problem

      I select the checkbox for storing data externally in the container, then I choose: import records > folder, I choose Picture and movie files and Import only a reference of each picture file. Actually, if I select to import only the reference of the files, it doesn't matter if I have selected to store externally the data in the container. The issue is the same, I'm not able to see the picture in the Instant Web Publishing in the browser.

      I upload the database from the Admin console in Filemaker Server. I also have tried to upload it from Filemaker pro 13 but it doesn't work. I cannot connect to the host. I've also used Filemaker pro 12 and stored the files in the Web folder but it doesn't work. The result is the same.

      Expected result

      A picture in the database when I access it in Instant Web Publishing mode in the web browser

      Actual result

      A missing image symbol

      Configuration information

      The container is optimized for static images