4 Replies Latest reply on Apr 23, 2013 5:29 PM by ZoXo

    IWP Crash

    ZoXo

      Summary

      IWP Crash

      Product

      FileMaker Server

      Version

      12.0v4

      Operating system version

      Mac OS 10.8.3

      Description of the issue

      On April 12th, IWP began crashing consistently.  I updated FileMaker server to version 4 two days later.  Issue persists.

      Steps to reproduce the problem

      Use IWP

      Expected result

      No Crash

      Actual result

      Web server is shut off by FileMaker Server.

      Exact text of any error message(s) that appear

      I can provide logs if someone knows how to read them.

      Configuration information

      Using across all browsers, all have crashed at some point.

      Workaround

      none

        • 1. Re: IWP Crash

               ZoXo:

               Thank you for the post.

                

               I have sent you a private message. Please check you inbox at the top of the page.

                

               TSFalcon

               FileMaker, Inc.

          • 2. Re: IWP Crash
            ZoXo

                 Update:

                 Reinstalled system OS

                 Reinstalled FileMaker Server 12v4

                 1 crash since server was started 1 day ago

                 At some point a firewall was installed ( unbeknownst to me ), so on this install, all FileMaker ports

                 were opened.  The 1 crash still concerns me though.  If it continues I will send along more crash reports.

            • 3. Re: IWP Crash
              ZoXo

                   Got a new certificate installed crashing has resumed ( 2 in the last hour )

                   Can a certificate cause IWP to do this?

              • 4. Re: IWP Crash
                ZoXo

                     Moved server to new location, sonic firewall, crashing continues.  I myself can use IWP without any issues, but when we ask the client to try, they are able to crash it within a few minutes.  Another team member has also been attempting to crash it but cannot.  We have ruled out that the plug-in is causing the issue and we have ruled out the location and firewall ( although that had it's own issues ).  I have removed all script steps that would log an error on IWP ( go to next record, go to related record, etc. ) and was able to run through 15 sessions without passing a single error.  We ask the client to give it a try and minutes later the web server crashes.  They are using every Windows browser available to test, I am using Safari.  Another team member has used every Windows browser as well, but could not get it to crash.  

                      

                     After investigation of the console logs, this process happens EVERY time the web server crashes.

                      

                     4/22/13 9:56:39.787 PM ReportCrash[47485]: DebugSymbols was unable to start a spotlight query: spotlight is not responding or disabled.
                     4/22/13 9:56:40.042 PM ReportCrash[47485]: failed looking up LS service ( scCreateSystemService returned MACH_PORT_NULL, called from SetupCoreApplicationServicesCommunicationPort, so using client-side NULL calls.
                     4/22/13 9:56:40.042 PM ReportCrash[47485]: LaunchServices/5123589: Unable to lookup coreservices session port for session 0x186a0 uid=0 euid=0
                     4/22/13 9:56:40.042 PM ReportCrash[47485]: failed looking up LS service ( scCreateSystemService returned MACH_PORT_NULL, called from SetupCoreApplicationServicesCommunicationPort, so using client-side NULL calls.
                     4/22/13 9:56:40.042 PM ReportCrash[47485]: LaunchServices/5123589: Unable to lookup coreservices session port for session 0x186a0 uid=0 euid=0
                     4/22/13 9:56:40.043 PM ReportCrash[47485]: failed looking up LS service ( scCreateSystemService returned MACH_PORT_NULL, called from SetupCoreApplicationServicesCommunicationPort, so using client-side NULL calls.
                     4/22/13 9:56:40.043 PM ReportCrash[47485]: LaunchServices/5123589: Unable to lookup coreservices session port for session 0x186a0 uid=0 euid=0
                     4/22/13 9:56:40.043 PM ReportCrash[47485]: failed looking up LS service ( scCreateSystemService returned MACH_PORT_NULL, called from SetupCoreApplicationServicesCommunicationPort, so using client-side NULL calls.
                     4/22/13 9:56:40.043 PM ReportCrash[47485]: LaunchServices/5123589: Unable to lookup coreservices session port for session 0x186a0 uid=0 euid=0
                     4/22/13 9:56:40.043 PM ReportCrash[47485]: failed looking up LS service ( scCreateSystemService returned MACH_PORT_NULL, called from SetupCoreApplicationServicesCommunicationPort, so using client-side NULL calls.
                     4/22/13 9:56:40.043 PM ReportCrash[47485]: LaunchServices/5123589: Unable to lookup coreservices session port for session 0x186a0 uid=0 euid=0
                     4/22/13 9:56:40.361 PM com.filemaker.syslogger[82]: Instant Web Publishing process has terminated abnormally.