5 Replies Latest reply on Jun 6, 2014 6:21 AM by srzuch

    Knowledge Base not filtering for your preferred language.

    srzuch

      Summary

      Knowledge Base not filtering for your preferred language.

      Description of the issue

      Provide a way to filter out foreign language articles in the Knowledge Base.  I like to review the most recent KB articles (last 7 days option), but sometimes the result listing is flooded with foreign (Japanese) language articles, like today.

      The preferred language setting in your profile should be respected in the KB.

      Steps to reproduce the problem

      Search for KB articles.

      Expected result

      Results only include articles in your language.

      Actual result

      Results included articles in Japanese.

        • 1. Re: Knowledge Base not filtering for your preferred language.
          TSGuy

               Steve Z,

               I attempted to reproduce what you are describing, but only received search returns in my language. Please post the following:

               - What search terms you are using

               - What OS (including exact version) you are using

               - What URL you are launching the search from

               - What browser (including exact version) you are using

                

               Thank you

          • 2. Re: Knowledge Base not filtering for your preferred language.
            srzuch

                 Search Terms: Only restrict by date -- Last 7 Days

                 Operating System: OS X Version 10.9.3

                 URL launching search from: http://help.filemaker.com  (before restricting by date)

                 Browser: Safari Version 7.0.4 (9537.76.4)

                 Under my Support Account Profile, my preferred language setting is English.

                 Japanese results started on page 2 today.

                 Thanks for looking into this.

                 Steve 

            • 3. Re: Knowledge Base not filtering for your preferred language.
              TSGuy

                   I'm afraid I'm still not able to reproduce this, but I suspect it is due to some back-end settings on our side. It will take us a few days to tweak and test them. When we believe we have it fixed, I'll post again.

                    

                   Thanks for your information (and patience!),

                   Modman

              • 4. Re: Knowledge Base not filtering for your preferred language.
                TSGuy

                     Though we were never able to reproduce this in-house, we have just pushed an update that we hope will address this. Please post here if you see the issue occur again. Please note that you may need to clear your browser's cache prior to retesting this.

                      

                     Thank you,

                     Modman

                      

                     P.S. Via this fix you may still see Chinese articles, but you should no longer see any in Japanese when searching in English.

                • 5. Re: Knowledge Base not filtering for your preferred language.
                  srzuch

                       The fact that many Chinese articles are still shown even though the language preference setting is English does not solve the problem.  Why we can't we filter the KB articles by language is beyond me.  Anyway, thanks for your time on this annoying, but insignificant issue. 

                       Steve