1 Reply Latest reply on Feb 19, 2014 9:57 AM by TSGal

    Layout part bottom border disappears if part can resize

    danshockley

      Summary

      Layout part bottom border disappears if part can resize

      Product

      FileMaker Pro

      Version

      12.0v4

      Operating system version

      Mac OS X 10.9.1

      Description of the issue

      You can add borders to a layout part, at least as of FileMaker 12. However, if that part is set to resize by having the "resize enclosing part" option selected for the object(s) within that part and there is a border on the bottom of that part, the bottom border will not render. Instead, the top, left, and right borders appear, but the bottom border is missing. That is unexpected and seems to be a bug.

      Steps to reproduce the problem

      Make a layout using a classic or printing theme.
      Make sure that "Delineate fields on current record only" is turned OFF for this layout.
      Add a bottom border (and optionally top, left, and right) to a part, for example the Body.
      Put a field in that part, making it a few lines tall.
      Make the part fit tightly against the bottom of that field.
      In browse mode, make a few records that have a mix of one or more lines of text in the field.
      Enter preview mode and observe the borders around the part.
      Back in Layout Mode, select the field in that part.
      From the Sliding & Visibility options in the Inspector:
      Select “Sliding up based on ‘Only objects directly above’”
      Also select “Also resize enclosing part.”
      Now, go back to preview mode and observe that the top, left, and right borders are still around the part, but the bottom border is gone, regardless of whether the part was able to resize smaller or not (which depends on the amount of text in the field).

      Expected result

      The bottom border should still be drawn, and at the location of the bottom of the part in its resized location.

      Actual result

      The bottom border disappears.

      Workaround

      Put a top border on any part following the part showing this bug. This does not always work well, or is not always possible.

      Layout_Part_Bottom_Border_Disappears.png