11 Replies Latest reply on May 12, 2015 12:20 PM by TSGal

    Layouts do not render colors properly in all browsers

    user12479

      Summary

      Layouts do not render colors properly in all browsers

      Product

      FileMaker Server

      Version

      v13

      Operating system version

      Windows, Macintosh

      Description of the issue

      Certain users with certain browsers fail to properly render layouts in Web Direct.  The theme is Ice.  We have not experimented with different themes - this is not practical as we are somewhat committed to the Ice theme.

      We find that certain users, using certain browsers, fail to properly render the colors for the layout. The error in rendering is always the same: I believe the background color (dark blue) becomes rendered in the foreground and overwhelms the top layer.  See attached screen shots

      Steps to reproduce the problem

      Open the database on certain PCs with certain browsers.
      I have seen the failure in Chrome and Internet Explorer, on Macintosh and Windows.

      Expected result

      Render correctly

      Workaround

      NONE !

      Bad_rendering.jpg

        • 1. Re: Layouts do not render colors properly in all browsers
          TSGal

          Ron Papajcik:

          Thank you for your post.

          I am unable to replicate the issue on my computer.  I have set a layout to the Ice Theme, hosted it with FileMaker Server 13.0v4 under Mac OS X 10.9.5, and have accessed the layout using Chrome 38 under Windows 7, Chrome 38 under Mac OS X 10.8.5 and Mac OS X 10.10.1, Safari 6.2 under Mac OS X 10.8.5, and Safari 8.0 under Mac OS X 10.10.1.  The layout renders properly on all browsers.

          On the Windows 7 machine, Microsoft Internet Explorer 9 is installed which is not supported.

          Can you provide more information about your computing environments?  Also, please provide more detail about the layout itself.  That is, are you using any custom styles?  If you create a new layout using the Ice Theme, do you still get the same issue?

          TSGal
          FileMaker, Inc.

          • 2. Re: Layouts do not render colors properly in all browsers
            user12479

            thanks for helping on this issue.  This is a big deal and I will appreciate your support.  I have identified a certain Windows 7 PC, with IE11, v11.0.9600.17420 where this database always failed to render properly.  On the same PC, with Chrome v39.0.2171.65m, it renders as expected.  Also, remember that this fails on certain Macs, too.  Other PC's and other Mac's will render as expected.

            I do not believe I have any custom styles.  To verify, I viewed every layout and with the Inspector / Styles tab / Show All checked, I noted the styles displayed.  All styles were 'default' and I did not observe any styles with a name other than 'default'.  So I conclude there are no custom styles.

            I created a new layout and placed three fields: the rendering problem still occurs on the new layout.

            I had a number of layouts with another theme, 'enlightenment'.  I changed all of those layouts to ice.  The render problem continues after changing all layouts to ice.  All layouts fail to render.

            Thanks for your continued assistance.

             

            • 3. Re: Layouts do not render colors properly in all browsers
              TSGal

              Ron Papajcik:

              I did find a Windows 7 machine with Internet Explorer 11, and I am able to replicate the issue.  I am still unable to replicate under all versions of Mac OS X (Safari and Chrome) as well as Chrome on Windows 7.

              I have sent along my findings to our Development and Testing departments for review.  When I receive any feedback, I will let you know.

              TSGal
              FileMaker, Inc.

              • 4. Re: Layouts do not render colors properly in all browsers
                user12479

                Thanks for your efforts - and I am happy you were able to reproduce it.

                Do you think this is an issue related to the theme, Ice ?

                Can you make it fail with other themes ?

                As a workaround while you guys fix the issue, should I consider a new theme ?

                Which, of course, is a big deal to change but we are trying to deliver this system.

                 

                For the record, a Mac user with Safari has reported the same problem.

                I believe there are combinations of certain browsers and certain PCs/Macintosh systems can fail.

                I have seen IE work OK on some PCs.

                 

                thanks

                 

                 

                • 5. Re: Layouts do not render colors properly in all browsers
                  TSGal

                  Ron Papajcik:

                  What version of Safari or Chrome is being used on the Macintosh systems?  Try emptying the cache to see if this is causing the issue.  For example, in Safari, pull down the Develop menu and select Empty Caches.  In Chrome, click the Chrome menu icon, select "More tools" or "Tools" (depending on version), and select "Clear Browsing Data...".

                  Although I don't have access to that Windows 7 machine until later today (as I will also clear the cache on the machine at that time), the issue may be related to the entire set of themes with a multi-colored border (Rectangle and Rounded).  I'll keep you posted.

                  TSGal
                  FileMaker, Inc.

                  • 6. Re: Layouts do not render colors properly in all browsers
                    user12479

                    thanks for your help.

                    I will confirm the version of Safari and Chrome with this one user.

                    I am sure we emptied cache at various times for troubleshooting.  I will try an experiment on my Windows 7 PC / IE 11 machine to confirm that combination.

                    Good to know it may be theme-wide.  If you can reproduce it, can you confirm if the theme Semi-Rounded / River is OK ?  I may need to move everything to a new theme ASAP - unless you can determine a fix is imminent.

                    thanks

                    Ron Papajcik

                     

                    • 7. Re: Layouts do not render colors properly in all browsers
                      TSGal

                      Ron Papajcik:

                      I can confirm that the issue occurs with each of the Rounded and Rectangular theme groups when using Internet Explorer 11 (even after cache was cleared).  I did not test with any other themes except default enlightened (which works).

                      TSGal
                      FileMaker, Inc.

                      • 8. Re: Layouts do not render colors properly in all browsers
                        user12479

                        I found another theme that fails - in Semi-Rounded, River fails, too.

                        Perhaps all Semi-Rounded fail ?

                        I am converting to Vibrant in the Aspire group.  So far, it is rendering as expected.

                         

                        regards,

                        Ron Papajcik

                         

                        • 9. Re: Layouts do not render colors properly in all browsers
                          TSGal

                          Ron Papajcik:

                          This appears to occur for any theme that consists of two colors in the Header part.  I am still unable to reproduce under Safari and Chrome.

                          TSGal
                          FileMaker, Inc.

                          • 10. Re: Layouts do not render colors properly in all browsers
                            philmodjunk

                            I knew this one sounded familiar. "two colors" finally gave me search criteria that worked to pull up past reports.

                            For More Information see:     Web Direct not displaying themes in web browsers

                            This is one of many acknowledged bugs that can be found in the Known Bug List thread here in the Report an Issue section of the forum.

                            It can also be downloaded as a database file from:    https://www.dropbox.com/s/jt09b82i0xijbu3/FMP%20Bugs.zip

                            • 11. Re: Layouts do not render colors properly in all browsers
                              TSGal

                              Ron Papajcik:

                              This issue appears to be fixed in FileMaker Pro 14.0.1.

                              TSGal
                              FileMaker, Inc.