10 Replies Latest reply on Mar 1, 2011 1:28 PM by TSGal

    License conflict with myself

    nutsonshells

      Summary

      License conflict with myself

      Description of the issue

      Hi, We have multiple databases hosted on our server and sometimes I am getting a license conflict with myself when I try to open an additional database from the server. I am using FM Advanced and it is a single license whereas all other users using a volume license, so they don't have the problem.Only one other person has the same problem sometimes as he is also using a single FM Advanced license. I checked all the external data sources, but they all look fine like:File Path: file: We have two IP addresses for opening files on the server, but even when using the same IP for all files it happens. Also I work sometimes from home and use a different IP for that, but as all File Paths are relative, it should not be a problem. What is the solution to fix this problem?It is quite annoying as it mostly requires to restart the computer. Thanks Regine  

        • 1. Re: License conflict with myself
          jsutherlin
             I am also having the same issue with FM9 Advanced and FM10 Advanced, both single license. Reboots of my mac are not helping. I can open the databases but as soon as I enter layout mode or try to manage the database I get the license conflict message...with myself. Currenly I am unable to even work on the databases.
          • 2. Re: License conflict with myself
            TSGal

            nutsonshells:

             

            Thank you for your post, and I apologize for the late reply.

             

            When FileMaker Pro launches, it looks across the network to see if anybody else is using the same license key, and if the network finds someone, you are presented with the license conflict information.  I know this doesn't apply to you, but other people reading this post may wonder what is occurring in the background.

             

            When accessing a database file hosted on FileMaker Server, information about the client is stored.  If you close the file, FileMaker Server should release that information.  If you crash, FileMaker Server may not know that you have disconnected, so it will keep that information active.  When you then try to log in again, you could get the license conflict error.

             

            The error can also occur if one of your hosted files is accessing a database file outside the subnet or firewall that then references another file inside the subnet/firewall.  Make sure this is not occurring.

             

            Since you already have FileMaker Pro open, try disconnecting from FileMaker Pro.  This should alert the network that you are no longer using FileMaker Pro, and FileMaker Server will release you as a client.  I agree you shouldn't have to do this, but I'm unable to determine what is causing the problem.

             

            Another possibility is the network itself holding onto the information, but since there is no network cache to manually clear, you could try to disconnect from the network and reconnect, but if that fails, then restarting the computer may be your only solution.

             

             

            jsutherliin:

             

            Your problem is similar, but restarting the computer is not working for you.

             

            What version of FileMaker Server is running?  How many files being served?  Are you able to work on any database file?

             

            Are you able to put those machines onto your local machine and use them?  Im sure you can, but I need to be thorough and ask the obvious.

             

            Anything else you can tell me about the other clients would be appreciated.  That is, are they also using a volume license copy of FileMaker Pro?  Do others run into the same problem with the license key conflict?

             

            Sorry I can't be more definitive.

             

             

            Please keep me posted with any progress.

             

            TSGal

            FileMaker, Inc. 

             

             

             

            I am also having the same issue with FM9 Advanced and FM10 Advanced, both single license. Reboots of my mac are not helping. I can open the databases but as soon as I enter layout mode or try to manage the database I get the license conflict message...with myself. Currenly I am unable to even work on the databases.
            • 3. Re: License conflict with myself
              JohnDuncan

              This problem is also occurring on FileMaker Pro 11 Advanced.  Similar situation to what was previously described.  Single-user license for FileMaker connecting to a 10.0v2 server advanced hosted on OS-X Server 10.5.8.  The FMPA 11 license key is installed on one machine only.

               

              I open a database on a remote server.  My computer has a private IP address through a router to the Internet and the FileMaker Server which itself is behind a router and has a private IP address.

               

              I start working with the remote database and all appears well.  I then generate a DDR, or open the Define Database, or open the Data Viewer and I get knocked off with the License key in use error.  The problem does not occur if I use a VLA version of FMPA so I know it is not a connectivity issue.

               

              We will be upgrading the server to FMSA 11 soon.  I'll post again if the problem re-occurs after the upgrade.

              • 4. Re: License conflict with myself
                GuidoWenzl

                I did have the same problem today and found y solution for me:

                while I was working with a database on the same computer I created a external relation to a file using the 127.0.0.1 address (used it for developing php files while on the road). Once I removed this relation everything is working fine again. 

                • 5. Re: License conflict with myself
                  drdocb

                  I am having a similar but different issue . FM Server 11 and FM advanced 11 - I am opening a runtme solution off the server that runs fine but when I also want to open a standard datafile I get a not enough licenses in Filemaker Pro error - Do I need to get another license?  It seems the runtime solution is limiting the opening of my other datafile but unsure. If I try to open the runtime solution directly it hangs since it may be looking for its datafiles in a set location on the local drive.

                  • 6. Re: License conflict with myself
                    TSGal

                    drdocb:

                    Thank you for your post.

                    Are you trying to launch the Runtime solution?  Or, are you using FileMaker Pro to access the database file bound in the Runtime solution?  If the latter, FileMaker Pro should then allow you to access other files.  If the former, you can't open files directly unless they are specified in the Runtime solution.  If they are referencing a file with no path, then the Runtime will search the machine for those files.  In this case, you may want to specify where the files are located when develping the Runtime solution.

                    TSGal
                    FileMaker, Inc.

                    • 7. Re: License conflict with myself
                      johnnykrz

                      I am using FM Advanced 11 and FM Server Advanced 11. I have this same problem. It occurs when I have a file open and then open another file which references the open file. It seems that rather than using the already open connection to the file, it tries to open a second connection to the server causing a license conflict. I was trying to import a script from a related file (that was not open) and it could not be done no matter how I approached it without removing the relationship. I ended up launching FM Pro to import the script.

                      I have checked to make sure I am not accessing the server from different IPs. It seems that FM Server could allow as many connections as you want to the same file as long as it is identified as the same machine (by IP, MAC, UUID, or something). Or is there a fix?

                      • 8. Re: License conflict with myself
                        TSGal

                        JohnnyKrz:

                        Thank you for your post, and I apologize for the late reply.

                        This issue of license key conflict with yourself was addressed in FileMaker Pro 11.0v2.  If you are using FileMaker Pro 11.0v1 and FileMaker Server 11.0v1, then please update to the latest releases from our web site.

                        Opening a second file that relates back to the first file should not create a new connection.  How are the files being referenced?

                        I know some time has passed, so if you have found a solution or workaround, please post here so others can benefit.

                        TSGal
                        FileMaker, Inc.

                        • 9. Re: License conflict with myself
                          johnnykrz

                          I am running FM Adv 11v3 and FM Server Adv 11.0.2.217. I still have this problem with one situation in particular that I can recreate every time.

                          Long story short, I have two databases. One has resident addresses that we deliver newsletters to (I'll call 'residents') and the other has our 'customers', the advertisers. The customer database is sort of central to all of our operations and some other databases share value lists from it and maybe some relationships. However, in this example, the resident database only shares a value list and there is a script within the residents that calls a script from the customers to export the customer addresses which are then imported and merged within the residents, but this script wouldn't be a problem upon opening a file and runs fine when we run it. There is no relationship going the other way, where the customer database accesses any data from the residents.

                          What happens is that if either database is open, I cannot open the other one at the same time without the conflict. I have to close one before opening the other for it to work. I've tried minimizing the depency that the residents have on the customers, but there really isn't much. I've just learned to deal with it for now.

                          • 10. Re: License conflict with myself
                            TSGal

                            JohnnyKrz:

                            When you open Customers, have you tried attaching an opening script that opens the Residents file?

                            Since this only seems to occur with these two files, have you tried recovering the files and see if the recovered files work properly?

                            TSGal
                            FileMaker, Inc.