7 Replies Latest reply on Mar 5, 2010 10:41 AM by ff_mac

    Linked Server

    robm26

      Summary

      Linked Server & DataDirect ODBC : Requested conversion is not supported error on Text field

      Description of the issue

      Hi, I'm having a problem described as follows :- FileMaker Product(s) involvedFileMaker Pro 8.5 database, running on a FileMaker 8 Server.DataDirect 32-BIT SequeLink 5.4 ODBC driver- Operating System(s) involvedWindows Server 2003- Detailed description of the issueWe also have MS SQL Server 2005 and I'd like to be able to share data between SQL and FileMaker via a SQL Server Linked Server.- Exact steps to reproduce the issueOn the SQL Server host, I installed the the FileMaker-provided "DataDirect 32-BIT SequeLink 5.4" driver and configured an ODBC data source to point to our FileMaker database.Within SQL Server, I setup a "Linked Server" that uses the ODBC source (via the MSDASQL provider).Now, I'm able to connect and access FileMaker tables with a SQL Query, but only certain columns.I can SELECT column types Calculation, Number, and Date and see the results.- Expected ResultI'd expect to be able to SELECT non-null values from a Text column (Indexed or Global Text).- Actual ResultError when Text column exists in SELECT statement.- Exact text of any error message(s) that appearedThe error is:OLE DB provider "MSDASQL" for linked server "JAFAR" returned message "Requested conversion is not supported."- Any additional configuration information/troubleshooting that is relevant to the issue I scoured the Internet and FileMaker web sites for the solution, and have two questions: 1. FileMaker suggested getting the latest ODBC driver, however I don't see any link to download this (DataDirect reports that SequeLink 6.0 exists). 2. Someone suggested the following workaround, is this the best solution to the problem ? johngale posted on MSDN.microsoft.com :  The text field problem using a linked server is caused by an unfortunate design decision in the DataDirect 32-BIT SequeLink driver.    A workaround is to add a "maximum number of characters" in the text field validation option settings in the Filemaker database.   In FMPro 8.5 this is done by: File|Define|Database|{select the field name of the text field}|Options|Validation|{enter a "Maximum number of characters" value.Thanks,Rob McCauleyCognexNatick MA