1 2 Previous Next 27 Replies Latest reply on Jan 9, 2014 12:55 PM by johnhorner

    List view is not displaying all records after scrolling.

    johnhorner

      Summary

      List view is not displaying all records after scrolling.

      Product

      FileMaker Pro

      Version

      13.0 v1

      Operating system version

      OSX 10.9.1

      Description of the issue

      I have a layout set up in list view to display a small number of records (<20). A script produces this found set and opens a new window to display the records. This works fine. However, when an attempt is made to scroll down to records not visible in the window, a section of records goes "blank".

      Steps to reproduce the problem

      Happens every time with this layout.

      Expected result

      All records in found set would appear normally as user scrolls through them.

      Actual result

      A section of varying length of the records goes "blank". Some records are visible above this blank section. And some records are visible below it. Note, the blanked out section is not fixed at a discreet number of records. some records are shown as a partial row/record (above and below the blank area).

      Exact text of any error message(s) that appear

      None.

      Configuration information

      file is hosted in the could and connected to using open remote.

      Workaround

      Either resizing the window by dragging it larger or smaller resolves the issue. Or refreshing the window using the keyboard shortcut resolves the issue (A refresh window final script step does not make any difference).

      Screen_Shot_2014-01-07_at_2.25.13_PM.png

        • 1. Re: List view is not displaying all records after scrolling.
          TSGal

               johnhorner:

               Thank you for your post.

               If you create a new layout and include the one field, does the issue still occur?

               Is the file hosted with FileMaker Server or FileMaker Pro?  If FileMaker Server, is FileMaker Server running under Mac OS X or Windows?

               Do you have any plug-ins installed?  If so, disable them and try again.

               What Theme are you using for the layout?

               Any other information you can provide may be helpful in narrowing down possible causes.

               TSGal
               FileMaker, Inc.

          • 2. Re: List view is not displaying all records after scrolling.
            johnhorner

                 here is a little more information:

                 if i create a new layout, the same problem occurs on the new layout.

                 i believe the fie is hosted with a "shared" server (i don't know much about this... i't is hosted through a company called triple8.net)

                 if the file is run locally, the problem does NOT occur.

                 if the file is hosted with filemaker pro adv 13, and it accessed over the lan using open remote from a workstation running fm 12, the problem does NOT occur. and vice versa, hosted on 12 and accessed via open remote using 13 the problem does NOT occur.

                 i am not using any plugins.

                 i did notice another somewhat strange behavior. if i scroll very slowly, the blank section consistently appears to start just after the first record. if i scroll quickly, the blank section consistently starts about 2 1/2 records down the list (see attached screen shot).

                 hope that helps. please let me know if i can provide any more information. thanks.

            • 3. Re: List view is not displaying all records after scrolling.
              TSGal

                   johnhorner:

                   Thank you for the additional information.

                   I am still unable to replicate the issue.  I have the file hosted on FileMaker Server 13 (Windows Server 2008) and accessed remotely by FileMaker Pro 13.0v1 on both Mac OS X 10.9.1 and Windows 7.  (Below is my screen shot from Mac OS X 10.9.1).

                   In the old layout, what Theme is being used?  In the new layout, what Theme is being used?

                   Any other information you can provide to help me replicate the issue would be appreciated.

                   TSGal
                   FileMaker, Inc.

              • 4. Re: List view is not displaying all records after scrolling.
                philmodjunk

                     TSFalcon, Is your server on the same LAN as your client?

                     This is not the case for JohnHorner as he is using a Hosting service to host the database. Thus there appear to be WAN vs LAN differences in your test configuration and his configuration.

                • 5. Re: List view is not displaying all records after scrolling.
                  TSGal

                       PhilModJunk:

                       I am not on the same LAN as johnhorner.  In a private message with johnhorner, he mentioned there is some sensitive data being hosted on that server, and although he was willing to allow me access, I had to decline due to new privacy issues with FileMaker, Inc.  There is still a possibility that the issue is file related, so I have requested a clone (copy with no records) of the file to test.

                       TSGal
                       FileMaker, Inc.

                  • 6. Re: List view is not displaying all records after scrolling.
                    philmodjunk

                         That's not at all what I asked. I did not suggest connecting to his database at all.

                         I asked if YOUR test where you were unable to replicate the issue was with a Server on the Same LAN as your client or not. Since a WAN has a much larger number of possible data communication issues than a LAN, it's possible that you won't be able to replicate his results without using a remote host.

                    • 7. Re: List view is not displaying all records after scrolling.
                      TSGal

                           PhilModJunk:]

                           Sorry for the confusion.  The customer has the file hosted by a third-party, triple8.net networks, and FileMaker, Inc. does not have an account with triple8.net, so that would not put me on the same LAN as the customer.

                           I have seen other customers using Triple8.net as a hosting provider, so I don't believe triple8 is at fault.  I have seen slow scrolling issues (especially with early FileMaker Pro 12), but I have not encountered this type of issue that the customer describes.  That is why I want to check the customer file.  If I'm still unable to replicate the issue, then I'll try hosting the file on a remote server.

                           TSGal
                           FileMaker, Inc.

                      • 8. Re: List view is not displaying all records after scrolling.
                        philmodjunk

                             I don't think that Triplie8 is at fault either nor am I suggesting that you use them as a remote hosting site. But I am suggesting that you may not be able to reproduce this issue without using some kind of "outside the LAN" host for your test.

                        • 9. Re: List view is not displaying all records after scrolling.
                          johnhorner

                               hi tsgal, here is a screenshot of the hardware setup. also, just to re-iterate, i don't think it is a wan issue anymore because now that i know the steps to consistently reproduce the behavior, it occurs both when the file is opened locally (not hosted at all), and when the file is connected to over the lan with "open remote". i will make a new test file this afternoon to see if it is something particular to this solution/layout/theme etc, or a more general behavior.

                          • 10. Re: List view is not displaying all records after scrolling.
                            johnhorner

                                 hi tsgal,

                                  

                                 in exchanging emails with steve, i noticed a difference between our screenshots that may or may not be significant. your screenshots show a scroll bar at the right side of the window, whereas i do not see a scroll bar in my window when the problem is occurring. however, if, when the problem occurs, i resize the window slightly smaller, the problem resolves and the scroll bar appears. just one more piece of the puzzle. hope that is helpful.

                            • 11. Re: List view is not displaying all records after scrolling.
                              TSGal

                                   Your email was forwarded to me.  Thank you.

                                   Yes, I scrolled up and down in the window.  No issue whatsoever.

                                   I have my scroll bars set to "Always".  After changing scroll bars to "When scrolling" and replacing my mouse (scroll wheel was broken), I performed the same steps and I was still unable to replicate the issue.

                                   Try changing your scroll bars setting to "Always" and let me know the results.

                                   TSGal
                                   FileMaker, Inc.

                              • 12. Re: List view is not displaying all records after scrolling.
                                johnhorner

                                     sorry... this is a dumb question... but how do i set the scroll bars to "always"? i can't seem to find it in the layout setup or the inspector...

                                • 13. Re: List view is not displaying all records after scrolling.
                                  TSGal

                                       johnhorner:

                                       Sorry for my assumption.  Scroll bars is a System Preferences setting.  Pull down the Apple menu and select "System Preferences...".  After the System Preferences window appears, click the "General" icon in the upper left.  Below the first three pop-ups is "Show scroll bars".  To the right of that, select the option "Always".  At this point, you do not need to close System Preferences, so launch FileMaker Pro and try the same steps again.  If this still fails, you can revert your scroll bars setting.

                                       TSGal
                                       FileMaker, Inc.

                                  • 14. Re: List view is not displaying all records after scrolling.
                                    johnhorner

                                         ahhh... ok. that is interesting. when i set the scroll bars to always, the problem does not occur. but if i reset it to "automatically", the problem reappears. does this mean it is an osx problem?

                                    1 2 Previous Next