AnsweredAssumed Answered

List view layout renders different between layout and browse modes

Question asked by c.wagner1 on Feb 5, 2014
Latest reply on Feb 5, 2014 by TSGal

Summary

List view layout renders different between layout and browse modes

Product

FileMaker Pro

Version

13

Operating system version

OSX 10.7.5

Description of the issue

List view layout does not render correctly in FMP 13 Advanced.  The layout looks correct in layout mode, however when switching to browse mode the sub-summary part shifts left about 10 px.  When the same file is viewed in FMP 13 the layout renders correctly

Steps to reproduce the problem

1. Start with a file in the FMP7 format. 
2. Convert it to FMP12 using FMP 12 Advanced.
3. Open file with FMP13 Advanced
4. Create list view layout with a header, sub-summary (Issue exists with body part as well but my screen shots show it occurring in a sub-summary part), and footer
5. Place elements in all 3 parts, directly in a vertical line.  Be sure the elements do not come out of their expected parts
6. Switch to browse mode and notice the elements in the sub-summary part shift left 10 - 15 pixels.  (I think it shifts the width of the scroll bar)
7. Share the file over the network and view it from another computer using FMP 13
8. Notice the layout renders properly in browse mode on this other computer

Expected result

All layout parts should render in the same position in browse and layout mode.

Actual result

Body part renders a few pixels left

Exact text of any error message(s) that appear

None

Configuration information

OS X 10.7.5 on a 13" Late 2006 Macbook running FMP 13 Advanced
OS X 10.7.5 on a 13" Late 2006 Macbook running FMP 13
OS X Mavericks with Server.app on a 2013 Mac Mini i7 running FMP 13 Server
File is hosted on server and developed with FMP 13 Advanced

Workaround

Use FMP 13 Advanced only for development

wrong2.png

Outcomes