3 Replies Latest reply on Feb 5, 2014 12:19 PM by TSGal

    List view layout renders different between layout and browse modes

    c.wagner1

      Summary

      List view layout renders different between layout and browse modes

      Product

      FileMaker Pro

      Version

      13

      Operating system version

      OSX 10.7.5

      Description of the issue

      List view layout does not render correctly in FMP 13 Advanced.  The layout looks correct in layout mode, however when switching to browse mode the sub-summary part shifts left about 10 px.  When the same file is viewed in FMP 13 the layout renders correctly

      Steps to reproduce the problem

      1. Start with a file in the FMP7 format. 
      2. Convert it to FMP12 using FMP 12 Advanced.
      3. Open file with FMP13 Advanced
      4. Create list view layout with a header, sub-summary (Issue exists with body part as well but my screen shots show it occurring in a sub-summary part), and footer
      5. Place elements in all 3 parts, directly in a vertical line.  Be sure the elements do not come out of their expected parts
      6. Switch to browse mode and notice the elements in the sub-summary part shift left 10 - 15 pixels.  (I think it shifts the width of the scroll bar)
      7. Share the file over the network and view it from another computer using FMP 13
      8. Notice the layout renders properly in browse mode on this other computer

      Expected result

      All layout parts should render in the same position in browse and layout mode.

      Actual result

      Body part renders a few pixels left

      Exact text of any error message(s) that appear

      None

      Configuration information

      OS X 10.7.5 on a 13" Late 2006 Macbook running FMP 13 Advanced
      OS X 10.7.5 on a 13" Late 2006 Macbook running FMP 13
      OS X Mavericks with Server.app on a 2013 Mac Mini i7 running FMP 13 Server
      File is hosted on server and developed with FMP 13 Advanced

      Workaround

      Use FMP 13 Advanced only for development

      wrong2.png

        • 1. Re: List view layout renders different between layout and browse modes
          TSGal

               Christopher Wagner:

               Thank you for your post and screen shots.

               Are all objects anchored left and top?  Or, is it possible you have one of the objects anchored right so that it adjusts to the window size?  That is, drag the right edge of the window smaller and see if any part adjusts with the window size?

               If this isn't the issue, then I'd like to see a clone of your database file so I can try it here.  Check your Inbox at the top of this page for instructions where to send your file.

               TSGal
               FileMaker, Inc.

          • 2. Re: List view layout renders different between layout and browse modes
            c.wagner1

                 Hi TSGal,

                 I will be sending a clone of my database shortly.  This is not a anchoring issue, I checked it.  I have been investigating further and came up with the cause. The issue is in OS X itself.  If OS X is set to show scroll bars only when scrolling the layout mode does not match browse mode.  If OS X is set to show scroll bars always the body part renders in the correct position.

                 (This setting for OS X is under System Preferences->General)

            • 3. Re: List view layout renders different between layout and browse modes
              TSGal

                   Christopher Wagner:

                   I received your file.  Thank you.

                   In the dashboardCoversShipped layout, you don't have left anchors on the header items, so they are free to float horizontally.  If you size the window larger, you will see the header objects slide to the right.  The same applies for the other layouts.

                   Put left anchors on the boxes and text objects and the header information will no longer shift.

                   TSGal
                   FileMaker, Inc.