AnsweredAssumed Answered

Lost about 4 hours of work - No error Msgs from FMPro 11

Question asked by PhilipHubert1357 on Feb 2, 2012
Latest reply on Feb 11, 2012 by hschlossberg

Summary

Lost about 4 hours of work - No error Msgs from FMPro 11

Product

FileMaker Server

Version

11.04.404

Operating system version

Mac OS X 10.7.2

Description of the issue

I've been using FM since version(?) 2 or 3. We develop solutions for our customers (years of experience) and never ahd problems with it.... ...and yesterday after(?)20 years of experience with it an unbelievable error happened.  First let me explain the network configuration, i was working with a customer on its system. FM Server (Trial) v 11.04.404, FM Pro 11 (Updated), Server running on MiniMac 10.7.2 connected to a switch, Client running on an Mac, connected to the same switch. both computers have fixed IP.I was able to change the database, make modifications, write new scripts, and everything worked ok. After 4 hours of work i decided to make a backup of the DB from the database folder. The file was NOT there, nor i was able to find it on ANY computer. It seems i worked on virtual file on the client side and data was never written on the server side. We have time machine installed on both machines but i was not able to recover any file. It was simply not on the hard drive. Could this problem arise from a wrong switch configuration? I'm really speechless. I copied the database i wanted to work in the data folder and this was detected by the server, but after 4 hours it was not there. all work lost. any clues?

Steps to reproduce the problem

tried to copy a file in the data folder, open it up on the client, delete it from the server with the client still open, but FM Pro always gives an error (correctly) and does not allow you to work, so i was, till now unable to reproduce the error.

Workaround

Redo the work =)

Outcomes