1 Reply Latest reply on Aug 17, 2012 8:13 AM by BruceHerbach

    Lost/Phantom window  locks up FileMaker Pro  Advanced

    BruceHerbach

      Summary

      Lost/Phantom window  locks up FileMaker Pro  Advanced

      Product

      FileMaker Pro

      Version

      12.0v2

      Operating system version

      Mac OS X 10.6.8

      Description of the issue

      Script attached to OnRecordLoad script trigger should create an off screen window to run a process.  System fails to create or find the window.  Script pauses at this error and fails to complete. The error displayed is 112 "Window is missing"

      Using the debugger to either  force the script to continue or abort the script leaves the system non functional.  Clicking the window close button or menus produces a beep,  but no action.  Windows won't close, scripts won't run.

      Keyboard shortcuts to go into and out of layout/browse mode do work, but are not helpful.

      It's as if there is a dialog or modal window that can't be found waiting for a button to be pressed.

      Steps to reproduce the problem

      In this case,  I was working on a complex layout going into layout mode then browse mode repeatedly.  Everytime I entered browse mode the script trigger ran.  I had been working for quite a while and had many iterations of this before it was a problem.

      Expected result

      System would create and find the window, complete the process.

      Actual result

      Had to force quit FileMaker Pro Advanced

      Configuration information

      This has happened twice and produced a system crash report for both incidents.  If you want I can send them to you.

      Workaround

      Disable script trigger while working on layout.