11 Replies Latest reply on Sep 10, 2009 1:44 PM by TSGal

    Magnifying glass (Find mode) does not appear on layouts with a single field

    donjuancarlos_1

      Summary

      Magnifying glass (Find mode) does not appear on layouts with a single field

      Description of the issue

      I am using XP  and FM10 Advanced To reproduce, create a new layout in a database and put one field on it.  Enter Find Mode and voilà, no magnifying glass.   My workaround is detailed in this thread, but it's not a magnifying glass. http://forum-en.filemaker.com/fm/board/message?board.id=FM-en-4&thread.id=24899

        • 1. Re: Magnifying glass (Find mode) does not appear on layouts with a single field
          raybaudi
            

          Hi

           

          I think that it isn't a bug, but a feature.

           

          When you have a layout with more than one field, the magnifying glass shows up into any NOT active field and only if there is an active field.

           

          With a layout containing only one field ( the active one ), where do you want to put the magnifying glass ?

          • 2. Re: Magnifying glass (Find mode) does not appear on layouts with a single field
            mrvodka
              

            I agree that I think that it was intended behavior instead of a bug per se. However, like LaRetta pointed out in the other thread, it is half implemented. If you turn off field frames ( which I always do), there goes the "feature".

             

            Second, it would be nice to probably have it so that when no field is active, all the fields show it in find mode. 

            • 3. Re: Magnifying glass (Find mode) does not appear on layouts with a single field
              LaRetta_1
                

              raybaudi wrote:

              When you have a layout with more than one field, the magnifying glass shows up into any NOT active field and only if there is an active field.


              Oh, I know what it DOES but that doesn’t make it right.  The purpose of the Find Icon is to tell a User which fields are available for finding information (searches are not always available in all fields which is why we have ability to turn it off).  If a field (through behavior) is disallowed for Find, then the Find Icon also disappears.   But a User many times decommits (clicks outside a field onto the layout) while in Find Mode.  ALL Find Icons will then disappear and the User is now unable to know which fields are available in Find Mode.  The Find Icons, when NO fields are selected, should still display!  In the case of one field, who said the field was active?  If the cursor is in the field then of course the Find Icon wouldn't display in it.  But that is not the issue which is when NO fields are selected.

               

              And of course the other 'bug' is requiring 'Show Field Frames' before the Find Icon can even be used.  I would bet that most Developers uncheck 'show field frames'.  Both items are poorly implemented and a bug in most people's book. :smileyhappy: 
              • 4. Re: Magnifying glass (Find mode) does not appear on layouts with a single field
                TSGal

                Thank you all for your comments.

                 

                It sounds like an additional check box is needed in the Layout Setup to enable/disable the Find icons.  That way, you can turn off "Show Field Frames" and either show or not show the Find icons.  Comments?  Suggestions?  Where would the icons appear with no field frames?

                 

                Just trying to get a better picture before presenting the case.

                 

                TSGal

                FileMaker, Inc. 

                • 5. Re: Magnifying glass (Find mode) does not appear on layouts with a single field
                  mrvodka
                    

                  That would be nice although, I am not sure how many people would really be that upset with the icons always showing in find mode...

                   

                  I just dont like field frames as many other do not. Controlling the find icon with that option doesnt really help.

                   

                  Furthermore, as previously stated, I can possibly understand making it go away when the field is active but when no fields are active, then I think it makes sense to show the icon in all of the fields that are searchable.

                  • 6. Re: Magnifying glass (Find mode) does not appear on layouts with a single field
                    mrvodka
                       One additional thing. Perhaps the option can be even further optimized as an option by having it as a option under field behaviors ( defaulting to on when the field is checked to be entered in find mode )
                    • 7. Re: Magnifying glass (Find mode) does not appear on layouts with a single field
                      hschlossberg
                        

                      TSGal wrote:

                      It sounds like an additional check box is needed in the Layout Setup to enable/disable the Find icons.  That way, you can turn off "Show Field Frames" and either show or not show the Find icons.  Comments?  Suggestions?  Where would the icons appear with no field frames?


                       Should have been a separate checkbox right from the beginning.  Tying it to the field frame makes little to no sense to me, and the result is a feature that nobody ever takes advantage of because many, many people turn field frames off.  Why wouldn't the icons appear in the same place they do now, regardless of whether frames are turned on or off.

                       

                      • 8. Re: Magnifying glass (Find mode) does not appear on layouts with a single field
                        TSGal

                        mr_vodka and howards:

                         

                        Thank you for your comments.  I think we are all on the same page that this needs a separate option.

                         

                        howards - You said "Why wouldn't the icons appear in the same place they do now, regardless of whether frames are turned on or off?"

                        I was making a few screen "mock-ups", and the Find icons look like they are floating out in the middle of nowhere when Field Frames are disabled...  Maybe it takes some getting used to.  Then again, I'm not a graphics designer.  I'm just trying to build a better presentation when presenting this.

                         

                        Any additional thoughts/ideas would be appreciated.

                         

                        TSGal

                        FileMaker, Inc. 

                        • 9. Re: Magnifying glass (Find mode) does not appear on layouts with a single field
                          hschlossberg
                            

                          TSGal wrote:

                          howards - You said "Why wouldn't the icons appear in the same place they do now, regardless of whether frames are turned on or off?"

                          I was making a few screen "mock-ups", and the Find icons look like they are floating out in the middle of nowhere when Field Frames are disabled...  Maybe it takes some getting used to.  Then again, I'm not a graphics designer.  I'm just trying to build a better presentation when presenting this.


                           
                          I think most of us already either shade our fields or add our own borders, so that the field is obvious while in Find and browse modes.   Even without such visual identifiers, the magnifying glass would typically appear just to the right of the field's "label", making it appear as a button that, when clicked, would land the user in the desired field.
                          But your comment brings up another point about the field frames.  I personally have no problem with field frames while in Find mode, as this is indeed a special place to be.  But while in browse mode, they are en eyesore that interferes with my own interface design and may inadvertently highlight areas of the screen that take the user's focus away from where it should be.  So perhaps the other part of this Find icons issue is to include separate options for displaying field frames either in Browse and/or Find modes.

                           


                          • 10. Re: Magnifying glass (Find mode) does not appear on layouts with a single field
                            mrvodka
                              

                            howards wrote:
                            So perhaps the other part of this Find icons issue is to include separate options for displaying field frames either in Browse and/or Find modes.

                             


                             

                            That is an excellent suggestion Howard! :-)


                            • 11. Re: Magnifying glass (Find mode) does not appear on layouts with a single field
                              TSGal

                              howards:

                               

                              I agree with "mr_vodka".  Excellent suggestion!

                               

                              Sometimes I'm looking through the forest and don't see the trees!  I didn't have my fields a different shade, so it was ending up as white on white.  <head hung low>

                               

                              I have forwarded this entire thread to our Development and Product Management departments.  If you have any additional ideas for this topic, please let me know, and I'll attach them.

                               

                              TSGal

                              FileMaker, Inc.