AnsweredAssumed Answered

Memory Leak in FMPA 14 (32 bit) on Windows 7 (64 bit)

Question asked by SteveMorrisby on Aug 3, 2015
Latest reply on May 9, 2017 by TSGal

Summary

Memory Leak in FMPA 14 (32 bit) on Windows 7 (64 bit)

Product

FileMaker Pro

Version

14 Advanced  32 bit

Operating system version

Windows 7 64 bit

Description of the issue

Serious memory leak which caused FMPA 14 to bloat to over 3.2 Gb of memory used until it froze with an out of memory on Line 1 error message.

Scenario:  I was doing development work - mainly layout work, and mainly involving a fairly complicated layout - over a period of hours.
Memory allocation (from Task Manager) vs time is as follows:
  184Mb at 1222 after closing & reopening
  1024 Mb at 1400 after a bit more layout work & lunch break
  1271 Mb at 1420 after a bit more layout work
  1545 Mb at 1505 after a bit more layout work
  2218 Mb at 1600 - FM14 now going a bit slow
  2761 Mb at 1700 hrs
  2842 Mb at 1735 hrs
  3208 Mb at 1805 hrs out of memory at line 1 can't even close



Subsequently, after restarting I tried leaving it idle for 12 hours - and no noticeable increase.

I also tried with and without other programs running, but that made no difference.

Steps to reproduce the problem

Do about 6 hours solid development work on a fairly complex layout  (about 10 tab panels and about 9 portals), flipping between that & other layout and layout & browse mode and testing by runnning an insert file / insert picture script.

Expected result

a reasonable growth in memory utilisisatio - maybe up to half a Gb

Actual result

Over 3 gb until it ran out of memory

Exact text of any error message(s) that appear

Out of Memory at line:1


(I actually thought it originally said Out of Memory at line:571, but by the time I'd fired the snipping tool  (about 3 seconds) it showed:
"Out of Memory at line:1"

Configuration information

I used the 32 bit version of FM 14 as I'd had a problem with a previous install of 64 bit.
I had also heard of others having problems with the 64 bit version of FMP14

Workaround

Can only restart it. afaik.

Memory__3208_Mb_at_1805_hrs_out_of_memory_at_line_1_can%27t_even_close_.PNG

Outcomes