3 Replies Latest reply on Feb 27, 2012 5:57 AM by atalanta

    Modify Privilege Set doesn't "stick" on Hosted File

    atalanta

      Summary

      Modify Privilege Set doesn't "stick" on Hosted File

      Version

      FileMaker 11 v3 Advanced

      Operating system version

      Windows 7

      Description of the issue

      Trying to modify privilege sets because they were set "too strict". Went in and edited Staff and Boss and when I re-opened the file with [Full Access] my changes didn't take.

      Went in and edited just the Staff and the changes didn't take.

      Steps to reproduce the problem

      Go under MANAGE>SECURITY and make several changes or even create or duplicate a privilege set on a hosted file. Hosted with FMS 11 and using FMA 11

      Expected result

      Expected the changes to still be there when opening the file again.

      Expected the created privilege set to be there.

      Expected the duplicated privilege set to be there.

      Actual result

      The changes had reverted to a previous state.

      The created privilege set was blank but for an up/down arrow and cannot be deleted.

      The duplicated privilege set was blank but for an up/down arrow and cannot be deleted.

      Exact text of any error message(s) that appear

      No error messages

      Workaround

      The way I have been able to get around it is to make tiny changes. For example, for Staff change layouts from custom to view only. Close the file. Re-open the file. Go under records and change the view to YES for all the tables the user can view. Close the file. Re-open the file. Go under records and change the edit to YES or LIMITED for all the tables the user can edit. Repeat again and again until all the changes are made.

        • 1. Re: Modify Privilege Set doesn't "stick" on Hosted File
          rmanook

          Hi Atalanta,

          Thanks for posting.

          I've been unable to reproduce the issue in the following configurations:
          a. FileMaker Pro 11v4 on Mac 10.6.8 - FileMaker Server 11v4 on Mac 10.6.8
          b. FileMaker Pro 11v4 on Windows 7 - FileMaker Server 11v4 on Windows Server 2008

          Here are the steps I followed:
          1.  Using FIleMaker Pro, connect to the FileMaker Server Sample file
          2.  In Manage > Security create a new privilege set
          3.  Make changes to the privilege set (view fields, edit fields based on a calculcation, view layouts, etc.)
          4.  Duplicate the new privilege set
          5.  Save the current settings
          6.  Close the file
          7.  Using FIleMaker Pro, connect to the FileMaker Server Sample file

          The result was that all of the changes I made with the privilege set remained.  The duplicate privilege set also retained its previously saved settings.  If there are any steps or variables I'm missing please let me know to better reproduce the issue.

          In the meantime, try reproducing the issue in the FileMaker Server Sample file or even a brand new database.  Does the issue still occur?

          Thanks,
          tsturtle
          FileMaker, Inc 

          • 2. Re: Modify Privilege Set doesn't "stick" on Hosted File
            atalanta

            Well, it turned out that day that the file corrupted while I was working on it. It was restored from a clean backup and I made my permissions changes.

            I modified the permissions again yesterday (changed all the limited to YES and went to do the limiting with scripts). Today, scripts weren't working and Lo and Behold, all the LIMITED had reverted back to LIMITED.

            Now, it may be that the file got corrupted YET AGAIN (which I won't know until someone gets to the office and can check the backup logs), but you'd think this wouldn't keep happening.

            • 3. Re: Modify Privilege Set doesn't "stick" on Hosted File
              atalanta

              Talked to our system admin this morning and he said the file is fine, according to the server logs. The last time there was a problem with the file was on Friday, when I posted my report here.