1 Reply Latest reply on Sep 26, 2012 9:48 AM by CliveScott

    More information on send event

    CliveScott

      Summary

      More information on send event

      Product

      FileMaker Pro

      Version

      12

      Operating system version

      XP SP3

      Description of the issue

      This may be related to previous problem. It concerns containers and send event. Which sometimes fails.

      Steps to reproduce the problem

      Sequence of events:
      1)Set up container with store container data externally open storage.
      2)Turn the container into a button adding the script

      Set Variable [ $vf; Value:TestDB::Document ]
      Send Event [ open document/application; File Name: “$vf” ] [ Bring application to foreground ]

      This works fine. You can drag and drop files into the container and clicking causes the document to open.

      3)Change the container to secure storage.

      4)Drag and drop some more files.

      5)The script now fails.

      6)Change the container back to open storage.

      7)Script fails for any documents subsequently added  (and it also doesn't work for any documents which were added while the container was in secure storage).

      I can see that the documents have been stored (apart from those entered into secure storage). For example both these files are visible in the file system. Clicking opens the first but not the second. The second was entered after the DB had been converted to secure storage and then converted back to open storage. (Value of $vf).

      remote:Addoutput21.txt
      FILE:TestDB/Document/Addoutput21.txt

      remote:todolist.txt
      FILE:TestDB/Document/todolist.txt

      The error message is:
      The file "todolist.txt" could not be found and is required to complete this operation.
      Then you get the error:
      The previous script step, "Send Event", could not be completed because of an error. Do you wish to continue with this script?

        • 1. Re: More information on send event
          CliveScott

               I think this may be due to changing the directory from which I dragged the files. I have noticed that opening using send event always opens the original not the copy in the container directory!! (That's not what I expected). Also if you change the directory from which you are dragging files it cant find the file (I think this is because it is still looking in the old directory location). However you can reset where it is looking by right clicking and doing insert file.