3 Replies Latest reply on May 30, 2013 5:33 PM by kessingb

    Must choose file type for import to work correctly

    ktuley

      Summary

      Must choose file type for import to work correctly

      Product

      FileMaker Pro

      Version

      12

      Operating system version

      Mac 10.8

      Description of the issue

      in previous versions of FMP, when importing a file, leaving the type on All Available and choosing a .csv file, correctly identified the file type. in FMP 12, user must choose csv as the file type in order to import correctly.
      more specifically, if you attempt to import a csv file, with All Available selected, all fields attempt to import to one field.
      works properly if you choose csv file type.

      Same appears to happen for Tab-delimited files.

      Steps to reproduce the problem

      start import of file. leave file type as All Available. import csv, or tab-delimited file. all fields will be combined as one field

      however if you choose csv, or tab-delimited file type, and choose that file, all works as expected.

      This MAY be happening only with files that have "field data", "more field data",
      ie, comma separated, but with "" around field data.

      Expected result

      leaving file type as All Available, FMP correctly determines the file type.

      Actual result

      all fields of import file, line up as one field. unless file type is selected ahead of time

      Exact text of any error message(s) that appear

      n/a

      Workaround

      select file type before choosing file and import. Again this behavior was in FMP 11 and prior, seems to have been changed in FMP 12.

      Screen_Shot_2012-08-19_at_6.05.31_PM.png

        • 1. Re: Must choose file type for import to work correctly

          ktuley:

          Thank you for your post.

          I created a .csv file with a FileMaker Pro 12 database. That file contained 2 fields and 5 records with a combination of text, quotation marks and commas in every record and every field. I then imported that .csv file into a second FileMaker Pro 12 database with “All Available” for the file type selected.

          I got two source fields of data and imported into the two fields designated to match. I tested on both 10.7.4 and 10.8.

          Am I possibly missing a step to reproduce the issue?

          TSFalcon
          FileMaker, Inc.

          • 2. Re: Must choose file type for import to work correctly
            ktuley

            I'm wondering if there's something in the csv file being generated by my "mainframe" as it's those files that are having issues, not being recognized correctly.

            just did another test..... maybe it's not files with the csv extension, but a txt extension.

            I just tried with another file. comma delimited but with a txt extension. all fields per record imported into one field. change the extension from txt to csv and it imported correctly.   still using the all available files option.

            So I must have not payed close attention to the extensions. 

            That said, I know that in FMP 11, i never had it import into one field like it does now.

            Thanks for checkin and responding on this.

             

            Ken

            • 3. Re: Must choose file type for import to work correctly
              kessingb

                   I have the same issue but only with tab files. In 11, if I had a "tab" ending on the file it imported correctly. In 12, a txt and tab file are imported as a coma delineated file if you don't specifically select the file type as tab in the import dialog box.