5 Replies Latest reply on Nov 11, 2013 10:23 PM by Fred(CH)

    New glitch after upgrade to OS X 10.9

    KenBublitz

      Summary

      New glitch after upgrade to OS X 10.9

      Product

      FileMaker Pro

      Version

      11.0v4

      Operating system version

      Mac OS X 10.9

      Description of the issue

      To print a customers bill I do a find of unpaid invoices, sort, go to preview and then print. But for customers that allow me to email the bill, I follow the same sequence, except that when the print window opens I go the PDF menu and click on mail PFD. Then I either see the one page invoice in there body of the email, or a pdf file if there is more than one page.

      But since I upgraded to 10.9 the other day, I can no longer mail more than one page at a time. Regardless if I choose to print all pages or from 1 to 2, only the first page shows in the email. I have to send it and then eliminate anything that was on the first page before sending whatever is left.

      Is there a fix for this? Or am I stuck now that I upgraded OS?

      Steps to reproduce the problem

      I think I covered this in previous section.

      Expected result

      To be able to mail multipage invoices as pdf files.

      Actual result

      Only first page is being sent.

      Exact text of any error message(s) that appear

      No error messages

      Workaround

      None. Just as I said, to email one page of invoice at a time.

        • 1. Re: New glitch after upgrade to OS X 10.9
          TSGal

               Ken Bublitz:

               Thank you for your post.

               I am unable to replicate the issue.  This is what I have done.

               After launching FileMaker Pro 11.0v4 under Mac OS X 10.9, I open a database file with several records.  I then pull down the File menu and select Print.  In the Print dialog box, I make sure to select "Print: Records being browsed".  I click the PDF icon in the lower left, and select "Open PDF in Preview".  This confirms that all pages are being displayed.

               Next, I go to the Print dialog box again, select "Print: Records being browsed", click PDF in the lower left, and select "Mail PDF".  The records are processed, Mail (my default email application) launches, and a blank message displays with the PDF file attached.  The PDF only shows the first page in the Mail application, but when I move the file to the Desktop (or a folder) and open in Preview or Adobe Acrobat Reader, all pages display.

               Let me know what I'm doing differently than you so I can try to replicate.

               TSGal
               FileMaker, Inc.

          • 2. Re: New glitch after upgrade to OS X 10.9
            KenBublitz

                 Thank you for your efforts, TSGal. Unfortunately, when I followed your steps, which differ slightly from how I've been doing it for years, I still end up with an email with only page one of the invoice. It has to be a consequence of updating my mac OS, as I began noticing the change the first time I tried to email a bill I updated.

                 Perhaps I should have added in my original post that my database was originally created by my wife in 1996 using an older FileMaker version. Whenever I got a new version of FM Pro the software would convert my files to the new version. I have never sat down and redone my files from scratch using the newer version. Perhaps that is why you cannot recreate my problem.   

            • 3. Re: New glitch after upgrade to OS X 10.9
              Fred(CH)

                   Hi Ken,

                   Unfortunately, i am also unable to replicate with My MacBook mid 2009, OS X 10.9 and FileMaker 11.0v4 and steps you provided.

                   Maybe starting from scratch is a good radical solution, but maybe, reviewing your layout could be enough...

                   Just to test, if you create a brand new similar layout with some fields, can you replicate the issue ?

                   Bye, Fred 

              • 4. Re: New glitch after upgrade to OS X 10.9
                Markus Schneider

                     There were similar problems under 10.5/10.6 when I remember correctly. It was a problem with the printing system - one could reset the printer settings (using the control panel - there was an option for that, don't know if it's still the same under 10.9). 

                     Doing so, all custom settings (as custom page formats, etc) are lost - but maybe worth a try.

                      

                     Further on, from time to time, installing a brand new, vanilla system (instead of just updating) could be helpfull as well

                • 5. Re: New glitch after upgrade to OS X 10.9
                  Fred(CH)

                       Hi Markus,

                       I thought about this too, it is why i also tested to change the settings, for instance, tried to print only "one page" or only "current record".

                       During my tests, all the settings worked perfectly...

                       Bye, fred