11 Replies Latest reply on Jun 3, 2013 1:57 PM by wbaruch

    No control over IWP

    wbaruch

      Summary

      No control over IWP

      Product

      FileMaker Pro

      Version

      FMA-12

      Operating system version

      Windows Server database host, Windows 7 64-bit for FMA

      Description of the issue

      Working perfectly in production I have 11 applications using FMS11 Advanced on a Windows server working with FMP-11 Advanced on a 64-bit Windows 7 PC.
      Testing the same setup in FM-12 before deploying it, having converted all the databases successfully I'm unable to control which of the databases appear in IWP. 
      The: File > Sharing > Instant WEB Publishing On/Off switch simply doesn't work.  Arbitrarily some databases appear in IWP and others don't irrespective of what the switch is set to.

      Steps to reproduce the problem

      Start with various sized databases working in the above described setup in FM-11, some apps using multiple files.  Install FMS-12 in a test server and convert the databases using standard methods.  Everything works just fine as a client app, layouts, scripts, the lot.  IWP however shows some databases and not others irrespective of how they're set up in FMA-12

      Expected result

      IWP should be controllable as it was in FM-11

      Actual result

      No control over appearance of IWP databases.  Some show, some don't, the on/off switch doesn't work.

      Exact text of any error message(s) that appear

      No error messages, just garbage output.

      Workaround

      I haven't found a work-around.  The screen shot shows the app working in iwp but the switch is off.

      stealth-switched-off-but-on.JPG

        • 1. Re: No control over IWP
          Fred(CH)

               Hi William,

               Thank you for your post. Can you please bring some clarifications ?

               Because on your screenshot you are displaying the IWP sharing dialog of FileMaker Pro. However, on your post you are saying that the database are shared by FileMaker Server.

               As you know, FileMaker Pro sharing dialogs can only display local databases and not hosted databases. What did i misunderstood ?

               To be more clear : FMPA = Pro Advanced and FMSA = Server Advanced.

               Bye, Fred

          PS: Sorry for my english approximative 

          • 2. Re: No control over IWP

                 William Baruch:

                 Thank you for the post.

                  

                 The ON/OFF toggle for Instant Web Publishing in FileMaker Pro is to enable access to the file via the Instant Web Publishing (fmiwp) privilege set. This is an account privilege set and can be accessed through File > Manage > Security.

                  

                 To host the file on FileMaker Server 12 Advanced using Instant Web Publishing, this should be toggled to ON for the file. In order to not display the file in the Instant Web Publishing homepage, check the box in the screenshot below. 

                  

                 Please let me know if this was the goal or if I can answer any other questions. 

                  

                 Some additional resources that may be useful:

                  

            Instant Web Publishing with FileMaker 12

                  

            FileMaker 12 Instant Web Publishing Guide

                  

                 TSFalcon

                 FileMaker, Inc.

            • 3. Re: No control over IWP
              wbaruch

                    

                   Thanks for your reply, however with the Instant Web Publishing radio button set to on or off, it makes no difference, the check box is greyed out and doesn’t change.  In any case, for the moment I want only two of the database applications to be used in IWP because some are multi-file apps and don’t work as they should in IWP.  That was a later project.

                   Attached is the FMServer_Sample screen.  It's switched off but appears anyway in IWP.  Controls to change anything are gayed out and inoperative

                   William Baruch.

              • 4. Re: No control over IWP
                philmodjunk

                     The box that shows currently open files is empty. Open the file, return to this dialog, click a file to select it and then you should see your options available to select instead of being greyed out.

                • 5. Re: No control over IWP

                       William Baruch:

                       Thank you for the reply.

                        

                       The radio button makes a difference for FileMaker Pro as the host. That setting will need to be ON in order to host with FileMaker Pro's Instant Web Publishing feature. The various account's privilege set access determines file access using FileMaker Server 12 Advanced's Instant Web Publishing.

                        

                       1. Open the FMServer_Sample with FileMaker Pro 12

                       2. Go to File > Manage > Security

                       3. Highlight the "[Guest]" account.

                       4. Click "Edit…"

                       5. Click "Edit…" next to "Privilege Set: Web"

                       6. See screenshot below

                        

                       Does the Extended Privileges box have a checkbox for "Access via Instant Web Publishing (fmiwp)"?

                        

                       If so, the [Guest] account still has "Access via Instant Web Publishing (fmiwp)" when hosted on FileMaker Server, and the file will display on the Instant Web Publishing start page regardless of the toggle being ON/OFF in FileMaker Pro 12.

                        

                       To check the "Extended Privileges":

                        

                       1. Open the FMServer_Sample with FileMaker Pro 12

                       2. Go to File > Manage > Security

                       3. Choose the "Extended Prvileges" pane.

                       4. Check under "Used by Privilege Sets" for Keyword fmiwp and Description Access via Instant Web Publishing. 

                        

                       If any privilege sets, including those not associated to an account, are listed under "Used by Privilege Sets," then a link to the database will appear on the Instant Web Publishing start page. However, if only privilege sets not associated to an account are listed, then no one will be able to login. 

                        

                       Please let me know if further clarification is needed.  

                        

                       TSFalcon

                       FileMaker, Inc.

                  • 6. Re: No control over IWP
                    wbaruch

                         Got it, thanks!  Sorry it took a while to get back, I'm juggling a few things here.

                         William Baruch

                    • 7. Re: No control over IWP
                      wbaruch

                           Unfortunately I have to raise this issue again, the problem is not completely solved.  In FMP-11 there were a number of files who's iwp settings were incorrect.  Using replies to my earlier post I corrected all of them except one.   The attachment shows that a file called "Clinical_AVM"is not available in iwp because none of the accessing privilege sets uses the keyword "fmiwp".  But you can also see from the FMS-11 clipping that IWP appears activated for this file.  This doesn't seem to matter in FMP-11 because the file doesn not show in the iwp list, but after converting the file to FM-12 it does appear in the iwp file choices, which of course it shouldn't.  I don't see any other params that can affect this.

                      • 8. Re: No control over IWP

                             William Baruch:

                             Thank you for the reply.

                              

                             Is the goal for the "Clinical_AVM.fmp12" file to show in the list of hosted files or not to show in the list?

                              

                        To not show the file in the list, remove the "Access via Instant Web Publishing (fmiwp)" privilege from all accounts (active or inactive) OR open the file with FileMaker Pro 12 and check the box for "Don't display in Instant Web Publishing homepage" shown in my earlier screenshot. 

                              

                             If even a single inactive account (such as Guest) has the "Access via Instant Web Publishing (fmiwp)" privilege and the box is unchecked for "Don't display in Instant Web Publishing homepage," then the file will appear in the list on FileMaker's Instant Web Publishing homepage.

                              

                             TSFalcon

                             FileMaker, Inc.

                        • 9. Re: No control over IWP
                          wbaruch

                               1.  The goal is to not show it.  In fact in FMP-11 it doesn't show but after I convert the file to FMP-12 it does.

                               2.  No accounts have access to this file via iwp, see the attachment showing extended privileges.

                          3.  The check box:  "Don't display in Instant Web Publishing homepage" is greyed out and doesn't respond to a click.  See the attachment. 

                                

                          • 10. Re: No control over IWP

                                 William Baruch:

                                 Thank you for the reply.

                                  

                                 I do not see an attachment showing extended privileges; however, such a screenshot would only be able to show one account and not all accounts on the file. Every single account whether active or inactive will need to have the privilege removed, otherwise the file will display in the list. 

                                  

                                 Was every account on the file checked to make sure the privilege set is not enabled for all accounts?

                                  

                            To be able to check the box for for "Don't display in Instant Web Publishing homepage" try the following:

                                  

                                 1. Close the file on FileMaker Server 12

                                 2. Download the file locally and move to a computer with FileMaker Pro 12

                                 3. Open the file locally with FileMaker Pro 12

                                 4. File > Sharing > Instant Web Publishing

                                  

                                 When accessing the file with FileMaker Pro 12, even with FileMaker Pro 12's Instant Web Publishing set to OFF, the box can be checked for "Don't display in Instant Web Publishing homepage." Afterwards, the file can be reuploaded to FileMaker Server with the new settings.

                                  

                                 TSFalcon

                                 FileMaker, Inc.

                            • 11. Re: No control over IWP
                              wbaruch

                                   OK, many thanks, opening the file locally, checking the "Don't display..." etc box and re-uploading worked when all else failed.  No account had access to the file via iwp in Extended Privileges.