AnsweredAssumed Answered

ODBC Import Field Mapping

Question asked by scsctech on Jan 21, 2010
Latest reply on Feb 11, 2010 by TSGal


ODBC Import Field Mapping

Description of the issue

I attempted to report this issue via the web form bug reporting page, but the form errors out.  Below is the link to this form that is not working, so the web folks can take a look.  The issue is that field mapping does not display properly when attempting to do an import from an ODBC data source using a variable to pass the query when selecting  'Calculated SQL text' as the option for the question 'Specify query using:'. My specs: FileMaker 10 Pro Advanced client on OS X 10.5.8 using Actual's ODBC driver for MySQL. To reproduce the bug: 1) create a script and add a script step of 'set variable' and also 'import records'. 2) set your variable to be your SQL query.  Label the variable whatever name you want.  I used $sqlquery.  3) on the 'import records' script step, tick the checkbox labeled 'specify data source' then select 'ODBC Data...' in the specify data source drop-down. 4) authenticate to your ODBC data source. 5) after successful ODBC authentication, the 'Specify ODBC SQL Query' dialog box displays.  You have two options to pass the SQL query in the 'Specify ODBC SQL Query'.  Option 1 = 'Calculated SQL text' and Option 2 = 'SQL text'. 6) Select Option 1 ('Calculated SQL text') and then enter in your variable name that you created in step 1. 7) On the script step of 'import records', now select the drop-down of 'Specify...'. 8) This step is where you would want to do your visual field mapping.  Instead, the result is that the column (field) names from the ODBC data source are all blank, thus making this option virtually useless.  The workaround is to build the query using Option 2 from step 5.  Using Option 2 from step 5 properly displays the SQL column (field) names, thus allowing for visual field mapping.