12 Replies Latest reply on May 1, 2012 7:11 AM by MattLeach

    Pasting into field includes formatting

    MattLeach

      Summary

      Pasting into field includes formatting

      Product

      FileMaker Pro

      Version

      12

      Operating system version

      Win 7 Pro

      Description of the issue

      In previous versions of filemaker, when you copied information outside of filemaker and pasted that information into a filemaker field, the data would be pasted with no formatting and would use the font and size specified on the field.

      In filemaker 12, when you perform the same copy/paste, the data you copied is now pasted with formatting and ignores what the font and size set on the field are.

      See discussion for screenshots:
      https://fmdev.filemaker.com/message/80134#80134

      Steps to reproduce the problem

      copy data from outside source.
      paste into filemaker field.

      Expected result

      the data pasted should reflect the font and size specified on the field. should be pasted without formatting

      Actual result

      the data pasted is pasted with formatting

      Workaround

      2 workarounds possible:

      1. When pasting, hold Shift will pressing Ctrl V
      2. Auto enter calc on all fields: TextFormatRemove (Self)

        • 1. Re: Pasting into field includes formatting
          TSGal

          Matt Leach:

          Thank you for your post.

          The pasting from another source into FileMaker Pro includes the font size and style.  This has occurred in several previous versions of FileMaker Pro.  To paste without formatting, use Shift-Control-V (Windows).  You can find this information in the Help under:

          Home > Reference > Keyboard shortcuts (Windows) > Genreral keyboard shortcuts (Windows)

          As mentioned in the other link, if you just used Control-V to paste the data, then follow it up by pressing Control-Z to remove the formatting.

          TSGal
          FileMaker, Inc.

          • 2. Re: Pasting into field includes formatting
            hschlossberg


             To paste without formatting, use Shift-Control-V (Windows).

             

            I don't have it open right now, but I am 99% sure that this feature was removed from the Windows side for FM12.  

            • 3. Re: Pasting into field includes formatting
              MattLeach

              "The pasting from another source into FileMaker Pro includes the font size and style.  This has occurred in several previous versions of FileMaker Pro"

              The above statement is FALSE. This was not the case in FileMaker 11. When copying and pasting, it always used the Font and Size from the field, not the format from the copied text. I just went back to v11 and it indeed did NOT copy the font size and style.

              • 4. Re: Pasting into field includes formatting
                TSGal

                Matt Leach:

                The statement is true.  Therefore, let's take a closer look at your FileMaker Pro 11 file.  Do you have any special formatting for the field in question?  Do you have any conditional formatting set up for the field?  Do you have any script triggers associated with the field?

                Create a new Text field and enter "This is a test".  Highlight the contents "This is a test" (do not go into Layout Mode) and change the font, font szie to 18, and font style to bold.  Copy this to the clipboard.  Then, create a new record, put your cursor in the new field and press Control-V.  It should paste in with the new formatting.  Pressing Control-Z will remove the formatting.  Create another new record, put your cursor in the new field and press Shift-Control-V.  "This is a test" will appear in the default font, font size and style.

                If you are still unable to make this work, perhaps it is the database.  Therefore, create a new database file with one field and repeat the process.

                Keep me updated with any progress.

                howards - Shift-Control-V still exists in FileMaker Pro 12.

                TSGal
                FileMaker, Inc.

                • 5. Re: Pasting into field includes formatting
                  hschlossberg

                  howards - Shift-Control-V still exists in FileMaker Pro 12.

                   

                  Ah, it looks like it's only been removed from the Edit menu in 12.   But the Keyboard function does still work.

                  Thanks for the correction.

                  • 6. Re: Pasting into field includes formatting
                    MattLeach

                    In your previous post, you mention "Do not go into Layout Mode"

                    This is where it is happening. If i do all of the copying and pasting in table view, it works as you described. But who is actually going to go to table view to do this?? Certainly not an end user who has no idea there even is a table view. Everything i have mentioned is in layout mode.

                    I created 2 blank databases with 1 field each in both FileMaker 11 and FileMaker 12. I set the field in both databases to be Font: Arial, Size: 12.

                    I then copied (Ctrl C) a link of text from an email and pasted (Ctrl V) the same text into each file.

                    I would expect the result to be the same font, size in both databases but clearly it is not so something changed in FM12 in regards to pasting outside data.

                    I've attached a screen shot with side by side comparisons of both v11 and v12

                    • 7. Re: Pasting into field includes formatting
                      TSGal

                      Matt Leach:

                      Thank you for the screen shots.

                      I think you misinterpreted Layout Mode for Form View.  The screen shots above are Browse Mode; not Layout Mode, and they are displaying Form View in Browse Mode.

                      Which Email program are you using on Windows?  I don't have any email application on my Windows machines, but I'm willing to install and try it out.  I'm unable to replicate the problem using a browser (Firefox and Internet Explorer).  Regardless of the outcome, it appears there may have been an issue in FileMaker Pro 11 not pasting correctly from your Email application, but appears to be resolved in FileMaker Pro 12.

                      TSGal
                      FileMaker, Inc.

                      • 8. Re: Pasting into field includes formatting
                        philmodjunk

                        I have been able to reproduce this behavior change using windows Xp and MS word.

                        I typed some text into the MS Word window. I then selected a bold text style for some of the text and copied all the text to the clip board.

                        When I bring up FileMaker 11 and pull down the edit menu, I see the option "Paste Unformatted text". If I paste the copied text, it pastes as plain text.

                        When I change to FileMaker 12 and pull down the edit menu, I see "paste". If I paste the text into the field, I see the formatted text appear in the target field.

                        This brings windows machines in line with Mac systems where the text was always pasted with the text formatting included. It was only on the windows machines that formatting was not included when you pasted the text.

                        What can confuse the issue is that if I copy text from one fileMaker field and paste into another in FileMaker 11, it pastes with the formatting unlike pasting text copied from a different application.

                        The work around is the one that mac users have been using for quite some time:

                        Put an auto-enter calculation on the field that specifies this calcualtion: TextFormatRemove ( Self ) and then clear the "do not replace existing ..." option.

                        Then all pasted text will have formatting stripped out and it pastes as plain, unstyled text.

                        • 9. Re: Pasting into field includes formatting
                          philmodjunk

                          Curioser and Curioser.

                          When I copy bold text from this Post A Answer box. It pastes as bold text in MS Word but as plain text in both versions 11 and 12.

                          Thus, I am getting inconsistent results pasting formatted text into a text field in Filemaker 12 on an XP system.

                          • 10. Re: Pasting into field includes formatting
                            MattLeach

                            Thank you for the screen shots.

                            I think you misinterpreted Layout Mode for Form View.  The screen shots above are Browse Mode; not Layout Mode, and they are displaying Form View in Browse Mode.

                            Which Email program are you using on Windows?  I don't have any email application on my Windows machines, but I'm willing to install and try it out.  I'm unable to replicate the problem using a browser (Firefox and Internet Explorer).  Regardless of the outcome, it appears there may have been an issue in FileMaker Pro 11 not pasting correctly from your Email application, but appears to be resolved in FileMaker Pro 12.

                            Yes, my apologies, i meant Form View

                            I am using Outlook 2010. The email that i am copying from is a plain text email, not HTML. It's no isolated to email though, i've copied information from MS Word files as well as from a browser with the same results.

                            PhilModJunk is describing exactly what is happening as well in his post:

                            I typed some text into the MS Word window. I then selected a bold text style for some of the text and copied all the text to the clip board.

                            When I bring up FileMaker 11 and pull down the edit menu, I see the option "Paste Unformatted text". If I paste the copied text, it pastes as plain text.

                            When I change to FileMaker 12 and pull down the edit menu, I see "paste". If I paste the text into the field, I see the formatted text appear in the target field.

                            As PhilModJunk pointed out, i guess this behavior is typical on the MAC platform and now windows has been brought in line with how the MAC operates. If this is true then so be it and ill user the auto-enter calc of TextFormatRemove ( Self ), i just wanted to report this as this was not the behavior in v11.

                            • 11. Re: Pasting into field includes formatting
                              TSGal

                              Matt Leach and PhilModJunk:

                              Thanks for the additional information.

                              I was able to locate a Windows XP machine that has Microsoft Word (2007), and I am able to replicate the issue in FileMaker Pro 11 as it pastes unformatted text.  Thanks for sticking with me as I was able to understand the inconsistency.

                              TSGal
                              FileMaker, Inc.

                              • 12. Re: Pasting into field includes formatting
                                MattLeach

                                I should be thanking you, im not the best at describing problems and you kept on it lol.

                                Glad you were able to replicate, im not crazy after all lol.