AnsweredAssumed Answered

Portal not refreshing on new record

Question asked by Chrislikespie on Jun 20, 2014
Latest reply on Jun 22, 2014 by philmodjunk

Summary

Portal not refreshing on new record

Product

FileMaker Pro

Version

FileMaker Pro Advanced 13.0v3

Operating system version

Windows 7

Description of the issue

I have a simple portal with id=id field and am allowing creation of records in child table. When trying values into a field on the portal sometimes (50%) of the time when I tab to the next field in the portal, the data is not visible in the first field and it 'appears' as if I left it blank. It will not always do this, but when it does happen I have to hit the enter key to commit the record for the data to display. This seems to be a refresh issue.

Steps to reproduce the problem

When trying values into a field on the portal sometimes (50%) of the time when I tab to the next field in the portal, the data is not visible in the first field and it 'appears' as if I left it blank. It will not always do this, but when it does happen I have to hit the enter key to commit the record for the data to display. This seems to be a refresh issue.

The parent record was committed prior to clicking into the portal. This only occurs on the Windows platform. This is not an issue on Mac.

Expected result

I expect when I tab from field to field I see the content of the field I just filled out, but that is not always the case.

Actual result

About 50% of the time the data does not display in the field until I commit the portal record. I have verified that there are no layered fields. Just a plane edit box on the field.

Exact text of any error message(s) that appear

No error messages.

Configuration information

The parent record was committed prior to clicking into the portal. This only occurs on the Windows platform. This is not an issue on Mac. 
The relationship is primary_id = foreign_id

Workaround

I have no work around.

Outcomes