1 Reply Latest reply on Jul 7, 2009 9:47 AM by TSGal

    Portal Records have changed in IWP - Not saving

    user16062

      Summary

      Portal Records have changed in IWP - Not saving

      Description of the issue

      I have posted this problem in various forums and still don't have an answer. I am using the session model and a portal to control record navigation in IWP. The problem I am having is that if some changes a value that is displayed in the portal then anyone else navigating via that portal can't save changes and receives a message that "portal records have changed" and the second user(s) will lose their changes to the record they are working on even though it is a completely different record than the first person is working on. Is there a setting to bypass this message and allow all data to be saved?

        • 1. Re: Portal Records have changed in IWP - Not saving
          TSGal

          JShapiro:

           

          Thank you for your post.

           

          I am unable to duplicate the problem.  This is what I have done.

           

          1. I created two tables: Master and Lookup.

           

          2. I related both tables by the text field "ID".

           

          3. I entered many records into Lookup and a few into Master.

           

          4. On my Master layout, I included a portal into Lookup.  For each of my records in Master, I have at least one record in Lookup.

           

          5. I turn on Instant Web Publishing and allow access to all users.

           

          6. USER1 launches a browser on a Windows XP machine and accesses the hosted file.  USER2 launches a browser on an iMac and accesses the hosted file.

           

          7. USER1 makes changes to the portal records for record 1 (ID=1) as well as some changes to the Master table.

           

          8. USER2 makes changes to the portal records for record 2 (ID=2) as well as some changes to the Master table.

           

          9. USER1 submits the changes.  USER2 submits the changes.  No error messages.  Both records and portals are updated accordingly.

           

          Let me know what I'm doing differently, and I'll try to duplicate the problem here.

           

          TSGal

          FileMaker, Inc.